8.х Сделать "Жирным" текст узла дерева

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем dima128, 1 мар 2017.

  1. TopicStarter Overlay
    dima128
    Offline

    dima128

    Регистрация:
    1 мар 2017
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Программно создается на форме "Дерево" не знаю как сделать верхние узлы Жирным шрифтом.

    Код:
    /////Код
    
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        // Вставить содержимое обработчика.  источник http://infostart.ru/public/356823/
     
        // Создание и заполнение "обычного" объекта прикладного типа ДеревоЗначений,
        // который будет отображен на управляемой форме
        ДеревоОбъект = Новый ДеревоЗначений;
        ДеревоОбъект.Колонки.Добавить("Пометка", Новый ОписаниеТипов("Число"));
        ДеревоОбъект.Колонки.Добавить("Узел", Новый ОписаниеТипов("Строка")); 
        Для к1 = 1 По 3 Цикл
            СтрокаУ1 = ДеревоОбъект.Строки.Добавить();
            СтрокаУ1.Узел = "Узел"+к1;
         
            Для к2 = 1 По 3 Цикл
                СтрокаУ2 = СтрокаУ1.Строки.Добавить();
                СтрокаУ2.Узел = СтрокаУ1.Узел+к2;
                Для к3 = 1 По 3 Цикл
                    СтрокаУ3 = СтрокаУ2.Строки.Добавить();
                    СтрокаУ3.Узел = СтрокаУ2.Узел+к3;
                КонецЦикла;
            КонецЦикла;
        КонецЦикла;
     
        // Создание Реквизита формы типа ДанныеФормыДерево
        МассивДобавляемыхРеквизитов = Новый Массив;
        МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Дерево", Новый ОписаниеТипов("ДеревоЗначений")));      
        Для Каждого Колонка Из ДеревоОбъект.Колонки Цикл
            МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "Дерево")); 
        КонецЦикла;
        ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);
     
        // Преобразование объекта прикладного типа ДеревоЗначений
        // в реквизит управляемой формы (данные формы)
        ЗначениеВРеквизитФормы(ДеревоОбъект, "Дерево");
     
        // Создание элемента формы типа ТаблицаФормы для отображения дерева
     
        ЭлементДерево = Элементы.Добавить("Дерево", Тип("ТаблицаФормы"),Элементы.Группа5);
        ЭлементДерево.ПутьКДанным = "Дерево";
        ЭлементДерево.Отображение = ОтображениеТаблицы.Дерево;
        //ЭлементДерево.ОтметкаНезаполненного=Истина;
        Для Каждого Колонка Из ДеревоОбъект.Колонки Цикл
            НовыйЭлемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), ЭлементДерево);
            НовыйЭлемент.ПутьКДанным = "Дерево." + Колонка.Имя;
            Если НЕ Колонка.Имя = "Пометка" Тогда
                НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
                //НовыйЭлемент.Шрифт.Жирный=Истина;
            Иначе
                НовыйЭлемент.Вид = ВидПоляФормы.ПолеФлажка;
                НовыйЭлемент.ТриСостояния = Истина;
                НовыйЭлемент.УстановитьДействие("ПриИзменении", "ФлажокПриИзменении");
             
            КонецЕсли;
        КонецЦикла;  
     
    КонецПроцедуры
    Последнее редактирование модератором: 2 мар 2017
  2. AlexeyKh
    Offline

    AlexeyKh Опытный в 1С

    Регистрация:
    27 июл 2012
    Сообщения:
    148
    Симпатии:
    19
    Баллы:
    29
    Самый простой вариант, используйте условное оформление формы
    выберите Жирный шрифт
    в Отборе добавьте ВаашеДерево.Узел Содержит "Узел"
    укажите оформляемые поля

    и все, у меня так работает

    Вложения:

    dima128 нравится это.
  3. TopicStarter Overlay
    dima128
    Offline

    dima128

    Регистрация:
    1 мар 2017
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо, вы мне очень помогли у меня всё получилось!