8.х УПП Счета затрат в документе Требование-накладная

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем nomas, 20 ноя 2016.

  1. TopicStarter Overlay
    nomas
    Offline

    nomas

    Регистрация:
    20 ноя 2016
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    1С УПП 1.3. В документе "Требование-накладная", если Вид Подразделения организации=Прочее, то автоматически не подставляются Счета затрат при указании Статьи затрат. Вид Подразделения организации=Основное производство, то все работает.
    Не могу разобраться, почему так происходит и как сделать так, чтобы для определенных Статей затрат счета учета проставлялись в том числе и для Подразделений организации с Видом=Прочее.
    Заранее огромное спасибо!
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.689
    Симпатии:
    955
    Баллы:
    204
    У УПП есть такая функция
    Функция ПолучитьСчетаУчетаСтатьиЗатрат(Подразделение, СтатьяЗатрат, КорСчет = неопределено) Экспорт
    ее посмотрите.

    там прописано как заполняется, все зависит от характера затрат
    Код:
    Если ПустаяСтатьяЗатрат И Не ПустоеПодразделение Тогда
    
            Если Подразделение.ВидПодразделения = Перечисления.ВидыПодразделений.ОсновноеПроизводство Тогда
                Счет = ПланСчетовБух.ОсновноеПроизводствоНеОблагаемоеЕНВД;
               
            ИначеЕсли Подразделение.ВидПодразделения = Перечисления.ВидыПодразделений.ВспомогательноеПроизводство Тогда
                Счет = ПланСчетовБух.ВспомогательныеПроизводстваНеОблагаемоеЕНВД;
               
            КонецЕсли;
    
        ИначеЕсли Не ПустаяСтатьяЗатрат Тогда
           
            Если СтатьяЗатрат.СтатусМатериальныхЗатрат = Перечисления.СтатусыМатериальныхЗатратНаПроизводство.ПринятыеВПереработку Тогда
                Счет = ПланСчетовБух.МатериалыПринятыеВПереработкуВПроизводстве;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.ОбщепроизводственныеРасходы Тогда
                Счет = ПланСчетовБух.ОбщепроизводственныеРасходыНеОблагаемыеЕНВД;
                ВидЗатратНУ = СтатьяЗатрат.ВидРасходовНУ;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.ОбщехозяйственныеРасходы Тогда
                Счет = ПланСчетовБух.ОбщехозяйственныеРасходыНеОблагаемыеЕНВД;
                ВидЗатратНУ = СтатьяЗатрат.ВидРасходовНУ;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.БракВПроизводстве Тогда
                Счет = ПланСчетовБух.БракВПроизводствеНеОблагаемоеЕНВД;
                ВидЗатратНУ = СтатьяЗатрат.ВидРасходовНУ;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.КоммерческиеРасходы Тогда
                Счет = ПланСчетовБух.КоммерческиеРасходыНеОблагаемыеЕНВД;
                ВидЗатратНУ = СтатьяЗатрат.ВидРасходовНУ;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.ИздержкиОбращения Тогда
                Счет = ПланСчетовБух.ИздержкиОбращенияНеОблагаемыеЕНВД;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.ВложенияВоВнеоборотныеАктивы Тогда
                Счет = ПланСчетовБух.СтроительствоОбъектовОсновныхСредств;
               
            ИначеЕсли СтатьяЗатрат.ХарактерЗатрат = Перечисления.ХарактерЗатрат.ПроизводственныеРасходы
                И Не ПустоеПодразделение
            Тогда
                ВидЗатратНУ = СтатьяЗатрат.ВидРасходовНУ;
                Если Подразделение.ВидПодразделения = Перечисления.ВидыПодразделений.ОсновноеПроизводство Тогда
                    Счет = ПланСчетовБух.ОсновноеПроизводствоНеОблагаемоеЕНВД;
                ИначеЕсли Подразделение.ВидПодразделения = Перечисления.ВидыПодразделений.ВспомогательноеПроизводство Тогда
                    Счет = ПланСчетовБух.ВспомогательныеПроизводстваНеОблагаемоеЕНВД;
                КонецЕсли;
                   
            КонецЕсли;
    
        КонецЕсли;
    
  3. Dfihte
    Offline

    Dfihte Новичок в 1С

    Регистрация:
    13 авг 2016
    Сообщения:
    5
    Симпатии:
    1
    Баллы:
    4
    Проблема, я думаю, возникает в том случае, если вы пытаетесь списать в Подразделение с видом Прочее на производственную статью. Этого делать в УПП нельзя Производственные затраты следует собирать на производственных же. Если вы выберете статью с характером Коммерческие расходы, издержки обращения или ОХР, то счет успешно подхватится. Скорее всего, вы выбрали статью не обратив внимание на ее характер. Создайте просто соответствующую статью.

Поделиться этой страницей