7.7 Сальдо на активно-пассивном счете

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем fantas, 6 апр 2007.

  1. TopicStarter Overlay
    fantas
    Offline

    fantas Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Как считать сальдо (начальное, конечное) на активно-пассивном счете?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Что значит считать??? Предприятие само считает и сальдо и обороты на основании движений документов.

    Можно пояснить вопрос?
  3. dend
    Offline

    dend Опытный в 1С

    Регистрация:
    9 апр 2007
    Сообщения:
    175
    Симпатии:
    0
    Баллы:
    26
    Запросом к бухитогам..
    Пример из типовой :

    БИ10 = СоздатьОбъект("БухгалтерскиеИтоги");
    БИ10.ИспользоватьСубконто(ВидыСубконто.Материалы, СписокМатериалов, 2);
    БИ10.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
    БИ10.ВключатьСубсчета(-1);
    БИ10.ВыполнитьЗапрос(,ТекущийДокумент(), "10",,,,, "СК");
    ..............
    Если ТаблицаОстатков.Материал.Вид() = "Материалы" Тогда
    ТаблицаОстатков.СчетУчета = ТаблицаОстатков.Материал.СубСчет10;
    БухИтоги = БИ10;
    БИ_НУ = БИ_НУМатериалы
    ..............
    Если БухИтоги.ПолучитьСчет(, ТаблицаОстатков.СчетУчета) = 1 Тогда
    Если БухИтоги.ПолучитьСубконто(1,, ТаблицаОстатков.Материал) = 1 Тогда
    ТаблицаОстатков.СуммаНаСкладах = Макс(БухИтоги.СКД("С"), 0);
    ТаблицаОстатков.КоличествоНаСкладах = БухИтоги.СКД("К");
    Если БухИтоги.ПолучитьСубконто(ВидыСубконто.МестаХранения,, МестоХранения) = 1 Тогда
    КоличествоНаСкладе = БухИтоги.СКД("К");
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;

Поделиться этой страницей