8.х РольДоступна

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем SkyNetYar, 11 апр 2017.

  1. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    Добрый день!
    Что то запутался ,хочу сделать доступность элементов на форме в зависимости от роли пользователя..

    В модуле документа
    Код:
    &НаСервере
    Функция ПроверкаРоли(Роль) Экспорт
      Возврат РольДоступна(Роль);
    КонецФункции 
    
    Код:
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    Если ПроверкаРоли("Мастер") Тогда
            Элементы.ОтметкаЗвонок.Доступность=Ложь;
        КонецЕсли;
    КонецПроцедуры
    

    Получаю
    {Документ.пмДокументСервиса.Форма.ФормаДокумента.Форма(286)}: Ошибка при вызове метода контекста (РольДоступна)
    Возврат РольДоступна(Роль);
    по причине:
    Недопустимое значение параметра (параметр номер '1')

    Помогите советом пожалуйста!
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.460
    Симпатии:
    52
    Баллы:
    54
    Добрый день!
    Начиная с версии Платформы 8.3, в случае когда не найдена в метаданных роль по указанному имени система вызывает Исключительную ситуацию, ранее система вернула бы результат Ложь.
    В Вашем случае, поскольку система вызывает исключительную ситуацию, значит запрашиваемой Вами роли в системе нет:
    1. Скопируйте роль прямо из метаданных
    2. Обновите конфигурацию, если она изменена и не обновлена.
    SkyNetYar нравится это.
  3. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    Все получилось!
    Большое спасибо!