8.х [РЕШЕНО] Слетает созданная мною роль, у администраторов системы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем b7music, 7 апр 2017.

  1. TopicStarter Overlay
    b7music
    Offline

    b7music Опытный в 1С

    Регистрация:
    21 июн 2016
    Сообщения:
    120
    Симпатии:
    5
    Баллы:
    29
    Добрый день! Проблема такая. Создал роль "Ивановы". В конфигураторе выдал эту роль нужным пользователям.

    В форме документа выполняется проверка на наличие этой роли:

    Код:
    //+b7music
    &НаСервере
    Функция ПроверкаРолиИвановы()
     
        Если НЕ РольДоступна("Ивановы") И Объект.Проведен Тогда
            Возврат Истина;
        Иначе
            Возврат Ложь;
        КонецЕсли;
    КонецФункции
    //-b7music
    Затем
    Код:
    &НаКлиенте
    Процедура ТоварыПослеУдаления(Элемент)
      
        // + b7music
      
        Если ПроверкаРолиИвановы()
            Тогда Отказ = Истина;
        КонецЕсли;
      
        // - b7music
    
    В итоге через 1-2 дня эта роль слетает. Захожу в конфигуратор, птичка снята. Такое только у тех пользователей, у кого есть роль "Администратор системы" и "Полные права" У других пользователей не слетает.
    Делал через группы и профили доступа в самой 1с, добавлял в группу, все равно слетает. Подскажите, из-за чего?
    kisol нравится это.
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.270
    Симпатии:
    966
    Баллы:
    204
    Люди тупо заходят и убирают эту роль :)
  3. TopicStarter Overlay
    b7music
    Offline

    b7music Опытный в 1С

    Регистрация:
    21 июн 2016
    Сообщения:
    120
    Симпатии:
    5
    Баллы:
    29
    Код:
    Если ПроверкаРолиИвановы()
    Тогда Отказ = Истина;
    Возврат;
    КонецЕсли;
    Забыл про возврат?

    Сами пользователи не убирают.
    Причем если зайти в группы доступа, то я включен в ту самую группу, к которой относиться созданная мною роль.
    Но пока через конфигуратор чекрыжик не поставить, не работает.
    Последнее редактирование: 7 апр 2017
  4. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    1.090
    Симпатии:
    23
    Баллы:
    29
    Синхронизацию ролей в режиме 1С предприятие с ролями в конфигураторе проводили? Обработкой с ИТС?
  5. TopicStarter Overlay
    b7music
    Offline

    b7music Опытный в 1С

    Регистрация:
    21 июн 2016
    Сообщения:
    120
    Симпатии:
    5
    Баллы:
    29
    Ну после того как создал роль в конфигураторе, запустил ИБ в режиме обновления. После этого моя роль стала доступна в самой платформе. У обычного пользователя, которому дал эту роль через конфигуратор она не слетает.
  6. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.270
    Симпатии:
    966
    Баллы:
    204
    Группа создана вручную?
  7. TopicStarter Overlay
    b7music
    Offline

    b7music Опытный в 1С

    Регистрация:
    21 июн 2016
    Сообщения:
    120
    Симпатии:
    5
    Баллы:
    29
    Да
    Screenshot_1.jpg Screenshot_2.jpg
    Разумеется в коде фамилия таже, что на скриншоте.
    Последнее редактирование: 7 апр 2017
  8. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.270
    Симпатии:
    966
    Баллы:
    204
    В этой же группе есть роли "Администратор системы" и "Полные права"?
  9. TopicStarter Overlay
    b7music
    Offline

    b7music Опытный в 1С

    Регистрация:
    21 июн 2016
    Сообщения:
    120
    Симпатии:
    5
    Баллы:
    29
    Имеете ввиду в профиле доступа?
    Нет, в профиле доступа 1 единственная созданная мною роль.
    В группе доступа в качестве профиля указан этот самый профиль. В неё включены как администраторы, так и обычные пользователи. Вот проблема только с теми, у кого есть полные права и администрирование.
  10. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.270
    Симпатии:
    966
    Баллы:
    204
    Видимо, типовые механизмы знают о том, что наличие роли "Админинистратор системы" и "Полные права" у пользователя освобождают от включения этому пользователю других ролей за не надобностью.
    b7music нравится это.
  11. TopicStarter Overlay
    b7music
    Offline

    b7music Опытный в 1С

    Регистрация:
    21 июн 2016
    Сообщения:
    120
    Симпатии:
    5
    Баллы:
    29
    Можно каким-либо образом исправить?
    Наверное единственный вариант
    Код:
    //+b7music
    &НаСервере
    Функция ПроверкаРолиИвановы()
        Если НЕ РольДоступна("Ивановы") И НЕ РольДоступна("ПолныеПрава") И Объект.Проведен Тогда
            Возврат Истина;
        Иначе
            Возврат Ложь;
        КонецЕсли;
    КонецФункции
    //-b7music
    p.s. да, при таком раскладе все работает как задумано.
    Последнее редактирование: 7 апр 2017

Поделиться этой страницей