8.х УТ Решение проблемы с ОбменСБанком (появляется с 11.1.2.6)

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем dimon_k, 9 июл 2013.

  1. TopicStarter Overlay
    dimon_k
    Offline

    dimon_k Опытный в 1С Команда форума

    Регистрация:
    17 янв 2011
    Сообщения:
    259
    Симпатии:
    17
    Баллы:
    29
    После обновления на 11.1.2.6 (сохраняется и в 11.1.2.8, 11.1.2.9) при условии что у вас несколько расчетных счетов в разных банках с одинаковыми системами програм Клиент-Банк при обмене будет ошибка. Решение этой проблемы прилагаю.

    В обработке "ОбменСБанком -> ОсновнаяФорма -> Модуль -> ЗаполнитьСписокПрограмм()" делаем изменения:
    Код:
      Если (ОбработанныйВладелец = Выборка.Владелец) и (ОбработаннаяПрограмма = Выборка.Программа) Тогда
    Если (ОбработанныйФайлЗагрузки = Выборка.ФайлЗагрузки) Тогда
    Если ТаблицаПрограммЗагрузки[ТаблицаПрограммЗагрузки.Количество()-1].Представление
    = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа) Тогда
    ТаблицаПрограммЗагрузки[ТаблицаПрограммЗагрузки.Количество()-1].Представление
    = ТаблицаПрограммЗагрузки[ТаблицаПрограммЗагрузки.Количество()-1].Представление + " ; " + Выборка.ФайлЗагрузки;
    КонецЕсли;
    Иначе
    Если ТаблицаПрограммЗагрузки[ТаблицаПрограммЗагрузки.Количество()-1].Представление
    = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа) Тогда
    ТаблицаПрограммЗагрузки[ТаблицаПрограммЗагрузки.Количество()-1].Представление
    = ТаблицаПрограммЗагрузки[ТаблицаПрограммЗагрузки.Количество()-1].Представление + " ; "
    + ОбработанныйФайлЗагрузки;
    КонецЕсли;
    
    СтрокаТаблицыПрограммЗагрузки = ТаблицаПрограммЗагрузки.Добавить();
    СтрокаТаблицыПрограммЗагрузки.Представление
    = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа)  + " ; " + Выборка.ФайлЗагрузки;
    СтрокаТаблицыПрограммЗагрузки.ПутьКФайлу = Выборка.ФайлЗагрузки;
    СтрокаТаблицыПрограммЗагрузки.Программа  = Выборка.Программа; // добавить эту строку
    СтрокаТаблицыПрограммЗагрузки.Организация = Выборка.Владелец; // добавить эту строку
    
    ОбработанныйФайлЗагрузки = Выборка.ФайлЗагрузки;
    КонецЕсли;
    
    Если (ОбработанныйФайлВыгрузки = Выборка.ФайлВыгрузки) Тогда
    Если ТаблицаПрограммВыгрузки[ТаблицаПрограммВыгрузки.Количество()-1].Представление
    = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа) Тогда
    ТаблицаПрограммВыгрузки[ТаблицаПрограммВыгрузки.Количество()-1].Представление
    = ТаблицаПрограммВыгрузки[ТаблицаПрограммВыгрузки.Количество()-1].Представление + " ; " + Выборка.ФайлВыгрузки;
    КонецЕсли;
    Иначе
    Если ТаблицаПрограммВыгрузки[ТаблицаПрограммВыгрузки.Количество()-1].Представление
    = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа) Тогда
    ТаблицаПрограммВыгрузки[ТаблицаПрограммВыгрузки.Количество()-1].Представление
    = ТаблицаПрограммВыгрузки[ТаблицаПрограммВыгрузки.Количество()-1].Представление + " ; "
    + ОбработанныйФайлВыгрузки;
    КонецЕсли;
    
    СтрокаТаблицыПрограммВыгрузки = ТаблицаПрограммВыгрузки.Добавить();
    СтрокаТаблицыПрограммВыгрузки.Представление
    = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа)  + " ; " + Выборка.ФайлВыгрузки;
    СтрокаТаблицыПрограммВыгрузки.ПутьКФайлу = Выборка.ФайлВыгрузки;
    СтрокаТаблицыПрограммВыгрузки.Программа  = Выборка.Программа; // добавить эту строку
    СтрокаТаблицыПрограммВыгрузки.Организация = Выборка.Владелец; // добавить эту строку
    
    ОбработанныйФайлВыгрузки = Выборка.ФайлВыгрузки;
    КонецЕсли;
    Иначе
    СтрокаТаблицыПрограммЗагрузки = ТаблицаПрограммЗагрузки.Добавить();
    СтрокаТаблицыПрограммЗагрузки.Представление = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа);
    СтрокаТаблицыПрограммЗагрузки.ПутьКФайлу = Выборка.ФайлЗагрузки;
    СтрокаТаблицыПрограммЗагрузки.Программа  = Выборка.Программа;
    СтрокаТаблицыПрограммЗагрузки.Организация = Выборка.Владелец;
    
    СтрокаТаблицыПрограммВыгрузки = ТаблицаПрограммВыгрузки.Добавить();
    СтрокаТаблицыПрограммВыгрузки.Представление = СокрЛП(Выборка.Владелец) + " ; " + СокрЛП(Выборка.Программа);
    СтрокаТаблицыПрограммВыгрузки.ПутьКФайлу = Выборка.ФайлВыгрузки;
    СтрокаТаблицыПрограммВыгрузки.Программа  = Выборка.Программа;
    СтрокаТаблицыПрограммВыгрузки.Организация = Выборка.Владелец;
    
    ОбработанныйВладелец  = Выборка.Владелец;
    ОбработаннаяПрограмма   = Выборка.Программа;
    ОбработанныйФайлЗагрузки = Выборка.ФайлЗагрузки;
    ОбработанныйФайлВыгрузки = Выборка.ФайлВыгрузки;
    
    КонецЕсли;
    И все начнет работать ...

Поделиться этой страницей