8.х Реквизит

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем John95103, 28 апр 2013.

  1. TopicStarter Overlay
    John95103
    Offline

    John95103

    Регистрация:
    23 апр 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    ВсемПривет!!!


    Как в поле реквизита вывести сумму табличной части?

    ЗаранееСпасибо

    Вложения:

  2. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Варианты:
    1. Создать реквизит документа СуммаПоДокументу. При записи документа в реквизит СуммаПоДокументу писать итоговую сумму по ТЧ.
    2. Создать реквизит формы списка и перед открытием считать Сумму

    1-ый вариант, оптимальнее.
  3. Inquisitive
    Offline

    Inquisitive

    Регистрация:
    25 апр 2013
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    !!! Данные действия только для управляемого приложения
    1. Создаем во вкладке "Данные" документа новый числовой реквизит - например: СуммаПоДокументу.
    2. Далее в форма документа размещаем следующий код:

    &НаКлиенте
    Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    РасчетНаСервере();
    КонецПроцедуры

    &НаСервере
    Процедура РасчетНаСервере()
    Объект.СуммаПоДокументу = Объект.РеализацияЗаказа.Итог("Сумма");
    КонецПроцедуры // РасчетНаСервере()

    РеализацияЗаказа - это наименование табличной части документа.
  4. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Лучше прописать это не в модуле формы, а в модуле объекта в процедуре "ПередЗаписью".
    Документ ведь может записываться не только из формы документа, но и из формы списка или какой-нибудь обработкой.

    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    СуммаПоДокументу = РеализацияЗаказа.Итог("Сумма");
    КонецПроцедуры
    

Поделиться этой страницей