7.7 Реквизит справочника тип данных - справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Реланиум, 28 сен 2006.

  1. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Как присвоить реквизиту справочника какое-то значение, если реквизит имеет вид Справочник(програмно)..
    Вопрос конечно нубовский, но такой я и есть.. :unsure:
  2. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Спр=СоздатьОбъект("Справочник.ИмяСправочника");
    Спр.НайтиПоКоду("1");
    ТвойРеквизит=Спр.ТекущийЭлемент();
    Если тип ТвоегоРеквизита "справочник неопределенного вида" то перед присвоением ставишь, например
    НазначитьВид(ТвойРеквизит,"ИмяСправочника")
  3. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    реквизит ешо и переодический.. Когда Карточка.Записать(); говорит нет даты :(
  4. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    если периодический, то используй метод ИспользоватьДату(Дата);
  5. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    пробовал пишет процедура не найдена
    вот код:
    Код:
    Процедура Выполнить()
    
    ИмущКомплекс=СоздатьОбъект("Справочник.Комплекс");
    ИмущКомплекс.НайтиПоКоду(7);  
    Карточка=СоздатьОбъект("Справочник.ОсновныеСредства");
    
    Карточка.НайтиПоКоду(12109);
    комплекс=ИмущКомплекс.НайтиПоКоду(7);
    Карточка.ИмКомп=ИмущКомплекс.НайтиПоКоду(7);
    
    Карточка.Записать();
    Сообщить(ИмущКомплекс.Наименование+"   "+ РабочаяДата() +"     "+Карточка.Наименование);
    КонецПроцедуры
    
    
  6. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Насколько я понял периодическим здесь является реквизит ИмКомп.
    Тогда напиши вот так:
    Процедура Выполнить()
    ИмущКомплекс=СоздатьОбъект("Справочник.Комплекс");
    Карточка=СоздатьОбъект("Справочник.ОсновныеСредства");
    Карточка.НайтиПоКоду(12109);
    ИмущКомплекс.НайтиПоКоду(7);
    комплекс=ИмущКомплекс.ТекущийЭлемент();
    Карточка.ИмКомп.Установить(РабочаяДата(),Комплекс);
    КонецПроцедуры
  7. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Ты как всегда прав пасибки.... :unsure:
  8. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Очередной трабл...
    Надо всем основным средствам с группой ПередаточныеУстройстрва04КВ Проставить этот дурацкий комплекс
    Реквизит Группа - тип перечисление (если это важно)
    ниче не делаеца хоть убей..
    Код:
    Процедура Выполнить()
    ИмущКомплекс=СоздатьОбъект("Справочник.Комплекс");
    Карточка=СоздатьОбъект("Справочник.ОсновныеСредства");   
    
    //Карточка.НайтиПоКоду(12109);
    ИмущКомплекс.НайтиПоКоду(7);
    комплекс=ИмущКомплекс.ТекущийЭлемент();   
    
    Карточка.ВыбратьЭлементыПоРеквизиту("Группа","ПередаточныеУстройства04КВ",1,0);      
    
    Пока Карточка.ПолучитьЭлемент()>0 Цикл       
    
    Карточка.ИмКомп.Установить(РабочаяДата(),Комплекс); 
    Сообщить("Видимо что то случилось...");
    КонецЦикла;
    
    КонецПроцедуры
    
    
    Один рас выводит фразу Видимо что то случилось.. и ниче не происходит.. :unsure:
  9. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    У реквизита "Группа" должен быть флаг Сортировка

    А тип реквизита "Группа" строка что ли?
  10. TAHk
    Offline

    TAHk Опытный в 1С

    Регистрация:
    31 авг 2006
    Сообщения:
    100
    Симпатии:
    0
    Баллы:
    26
    Можно потупому перебрать все элементы с внутренним условием...
    медленно, но верно :)
  11. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Тип Реквизита Группа Перечисление

    а чем от моего кода отличается?
  12. TAHk
    Offline

    TAHk Опытный в 1С

    Регистрация:
    31 авг 2006
    Сообщения:
    100
    Симпатии:
    0
    Баллы:
    26
    отличается:
    -----------------
    ...
    Карточка.ВыбратьЭлементы();

    Пока Карточка.ПолучитьЭлемент()>0 Цикл
    если Карточка.Группа=Перечисление.[имя перечисления].ПередаточныеУстройства04КВ тогда

    Карточка.ИмКомп.Установить(РабочаяДата(),Комплекс);
    Сообщить("Видимо что то случилось...");
    КонецЕсли;
    КонецЦикла;
    ...
    -------------------
    кажется так - не начем проверить
  13. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Карточка.Группа=Перечисление.[имя перечисления].ПередаточныеУстройства04КВ -ффсё равно чушь..
  14. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Если тип реквизита перечисление то и пиши тогда так:
    Карточка.ВыбратьЭлементыПоРеквизиту("Группа",Перечисление.ИмяТвоегоПеречисления.ПередаточныеУстройства04КВ,1,0);
  15. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    :unsure: опять поперло!!!
    пол часа делолася но ет не важно!!!
    Всем пасибо
Похожие темы
  1. scc
    Ответов:
    8
    Просмотров:
    2.036
  2. IMAXI
    Ответов:
    7
    Просмотров:
    873
  3. TRABANT
    Ответов:
    11
    Просмотров:
    606
  4. Poverina
    Ответов:
    15
    Просмотров:
    729
  5. MyBratva
    Ответов:
    4
    Просмотров:
    641
Загрузка...

Поделиться этой страницей