7.7 Реготчетность по НДС

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем daab, 22 апр 2015.

  1. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерия релиз 7.70.595

    Добрый день

    Формирует книгу покупок с большим количеством номеров ГТД, больше 1000 символов.
    В формате для налоговой количество символов не должно превышать 1000 символов

    Есть какое то решение на данный момент у кого?

    з.ы. Обрезку не предлагать
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    в отчете есть процедура.. Внесите изменения...
    Код:
    Функция СписокНомеровГТД(Док)
    
        Если Док.Выбран() = 0 Тогда
        ИначеЕсли (Док.Вид() = "СчетФактураПолученный") или
                  (Док.Вид() = "ИсправлениеСчетаФактурыПолученного") или
                  (Док.Вид() = "ПоступлениеТоваров") Тогда
    
            СписокГТД = СоздатьОбъект("СписокЗначений");
            Док.ВыбратьСтроки();
            Пока Док.ПолучитьСтроку() = 1 Цикл
                Если ФормироватьПоПостановлению735 = 0 Тогда
                ГТД = ?(ПустоеЗначение(Док.ГТД) = 0, СокрЛП(Док.ГТД.КодПоОКСМ) +
                    ";" + Док.ГТД, "");
                Иначе
                    ГТД = ?(ПустоеЗначение(Док.ГТД) = 0, Док.ГТД, "");
                КонецЕсли;
                Если СписокГТД.НайтиЗначение(ГТД) = 0 Тогда
                    СписокГТД.ДобавитьЗначение(ГТД);
                КонецЕсли;
            КонецЦикла;
            ГТД = "";
            Если СписокГТД.РазмерСписка() > 0 Тогда
                Для а = 1 по СписокГТД.РазмерСписка() Цикл
                    Стр=СписокГТД.ПолучитьЗначение(а);
                    Если СтрДлина(ГТД)+СтрДлина(Стр)<=999 Тогда
                        ГТД = ГТД + ?(ГТД = "", "", ";") + Стр;
                    Иначе
                         Прервать;
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
            Возврат ГТД;
        КонецЕсли;
        Возврат "";
    
    daab нравится это.
  3. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    осталось понять куда внедрить в отчет или в книгу?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Отчеты.КнигаПокупок1137
    Из этого отчета идет выгрузка
  5. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    так я понимаю он будет дробить ГТД по количеству символом?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Нет.. Дробить не будет. Возьмет столько ГДТ, чтобы длина строки не превышала 1000.
    Т.е. части ГТД не возьмет. Только целые значения
  7. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    так а как быть если гтд много, в каком формате их запихивать?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  9. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    в реготчет по ндс 2015 раздел 8
    к примеру у нас 1000 номеров ГТД, а под количество знаков влезает только 800, как с остальными быть?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вообще-то вопрос чисто риторический...
    Думаю (лично мое мнение) оставить только 800... Ибо у поставщиков продукции аналогичная ситуация (те же 800)
    "Кипиш" считаю преждевременным. История с НДС мне сильно напоминает ситуацию с алкоголем (РАР).
    Они сами только через 2.5 года более-менее "устаканились" и смогли "переваривать" полученную информацию.
    daab нравится это.
  11. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Благодарю)
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь
  13. Alb77
    Offline

    Alb77

    Регистрация:
    22 апр 2015
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    А можно попросить и для 7,7 (бух,торг, скла, з.пл) комплексная Формирует книгу покупок с большим количеством номеров ГТД, больше 1000 символов.
    В формате для налоговой количество символов не должно превышать 1000 символов ПОМОГИТЕ
  14. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    ну ответ же написали выше, буквально 1-й ответ
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Замените процедуру в книге покупок на указанную в посте №2

Поделиться этой страницей