8.х Регламентные задания

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем XXL, 10 апр 2009.

  1. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Здравствуйте.
    Прочитала в доументации про реглементные задания и ничего не поняла - что это, с чем едят, как работают и самое главное - какие манипуляции нужно сделать, чтобы получилось новое регламентное задание???
    То что в конфигураторе надо добавить новое задание, обозвать его и расписание ему сделать, это все понятно, а вот где и что прописать, чтоб например сообщалось "Привед" по расписанию ума не приложу :unsure:
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Регламентное задание не работает с интерфейсом - плохо читали. Оно выполняется на сервере и не имеет доступа к интерфейсу...
  3. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Тогда где и что нужно сделать на сервере??? С чего хоть начинать троганье сервера?
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Посмотрите в любой типовой регламентные задания - они просто вызывают определенную процедуру
  5. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    Немного не так. В клиент- серверном варианте работы планировщик заданий выполняется в менеджере кластера серверов (это можно заметить в консоли кластера как постоянно выполняющееся соединение "Планировщик заданий"). В файловом варианте нужно вручную запускать обработку ожидания проверки выполнения регламентных заданий
    Код:
    ВыполнитьОбработкуЗаданий()
    
    с каким-нибудь интервалом. Выполнить задания может только тот пользователь, который для них назначен. Или администратор. В типовых УПП и УТ за эту функцию отвечают константы "Интервал опроса регламентных заданий в файловом варианте" и "Пользователь для выполнения регламентных заданий в файловом варианте".
    Кстати, если невнимательно настроить эти константы, то можно встретить жуткие тормоза при работе :unsure:
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Если почитать справку, то там все это написано :)
  7. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    Ну, если бы все справку читали... :unsure:
  8. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    мда... не особо много информации можно вынести из справки. Это я и так знаю. Мне процесс надо, как чего делать.
  9. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    Книжка есть. Белоусов, Островерх. "1С:Предприятие: от 8.0 к 8.1." Питер, 2008 г.
    Рекомендую.
  10. Bonov
    Offline

    Bonov

    Регистрация:
    9 апр 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Если клиент-серверный вариант работы, то сервер трогать вообще не надо.
    Нужно создать новое регламентное задание, установить ему желаемое расписание, а затем назначить предварительно созданную процедуру в свойствах задания, которая будет выполняться в назначенное время. Причем необходимо, чтобы процедура была в том общем модуле, который доступен серверу (установлена галочка Сервер).

    Пример процедуры в общем модуле Processings:
    Код:
    //Процедура обновляет индекс полнотекстового поиска
    Procedure IndexUpdate() Export
    If FullTextSearch.GetFullTextMode() = FullTextMode.Enable Then
    If Not FullTextSearch.IndexTrue() Then
    FullTextSearch.UpdateIndex(False, True);
    EndIf;
    EndIf;
    EndProcedure
    
    
    Напоминаю: в регламентных заданиях доступны процедуры и функции, которые не требуют вмешательства пользователя, поэтому не доступны ни формы, ни диалоговые окна.
  11. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Bonov, спасибо. Хоть кто-то здесь может объяснить, как чего делать.
  12. KMC
    Offline

    KMC Опытный в 1С

    Регистрация:
    21 фев 2007
    Сообщения:
    53
    Симпатии:
    0
    Баллы:
    26
    Решил не плодить кучу тем по регламентным операциям и поэтому задам вопрос здесь. Меня интересует, а может ли регламентная операция работать с файлами. Т.е. считывать данные и обратно загружать.
    Пример такой обработки:
    Код:
    ФайлПоиска=Новый Файл(ИмяФайла);
    Если ФайлПоиска.Существует() Тогда
    ТекстовыйДокумент=Новый ТекстовыйДокумент;
    ТекстовыйДокумент.Прочитать(ФайлПоиска.ПолноеИмя);
    Номер=ТекстовыйДокумент.КоличествоСтрок();
    Пока Номер<>0 Цикл
    Стр=ТекстовыйДокумент.ПолучитьСтроку(Номер);
    Если Сред(Стр,1,1)<>"2" тогда
    Попытка
    ТекстовыйДокумент.УдалитьСтроку(Стр);
    Исключение 
    КонецПопытки;    
    Иначе 
    КонецЕсли;    
    Номер=Номер-1;
    КонецЦикла;            
    НеЗаписан=1;
    Пока НеЗаписан Цикл
    Попытка    
    ТекстовыйДокумент.Записать(ФайлПоиска);
    НеЗаписан=0;
    Исключение    
    КонецПопытки;       
    КонецЦикла;    
    КонецЕсли;    
    
    
    
Похожие темы
  1. dimon_k
    Ответов:
    1
    Просмотров:
    674
  2. Rad&K
    Ответов:
    1
    Просмотров:
    359
Загрузка...

Поделиться этой страницей