8.х Регламентное задание с параметром

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем KilloN, 28 мар 2014.

  1. TopicStarter Overlay
    KilloN
    Offline

    KilloN

    Регистрация:
    17 сен 2012
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    Конфа: Комплексная автоматизация, платформа 8.3
    Любопытная проблема, с некоторого времени перестало выполняться регламентное задание по обмену между базами. Если вручную обмен запустишь то все хорошо, если через регламентное задание то Ж.:confused:

    Возникает ошибка "Недостаточно фактических параметров для метода фонового задания".o_O

    Само регламентное задание типовое "ВыполнениеОбмена" которое вызывает процедуру:
    Код:
    Процедура ВыполнитьОбменДаннымиДляНастройкиАвтоматическогоОбменаДанными(КодНастройки) Экспорт
       
       Если НЕ ЗначениеЗаполнено(КодНастройки) Тогда
         Возврат;
       КонецЕсли;
       
       НастройкаОбмена = Справочники.НастройкиВыполненияОбмена.НайтиПоКоду(КодНастройки);
       
       Если НЕ ЗначениеЗаполнено(НастройкаОбмена)
         ИЛИ НастройкаОбмена.ПометкаУдаления Тогда
         Возврат;
       КонецЕсли;
       
       ПроцедурыОбменаДанными.ВыполнитьОбменПоНастройкеАвтоматическогоВыполненияОбменаДанными(НастройкаОбмена, Ложь);
       
    КонецПроцедуры
    Отладка естественно невозможна, т.к. не вызывается сама по себе процедура... Поэкспериментировав с самописной тестовой базой у меня такая ошибка возникает, когда я добавляю хотя бы 1 параметр без значения по умолчанию в процедуру регламентного задания!.

    Т.е. из-за параметра "КодНастройки" скорее всего и возникает данная ошибка!

    Однако посмотрев большинство типовых регламентных операций я увидел что многие содержат параметр! Например:
    Код:
    Процедура РасчетЦеныНоменклатурыРеглЗадание(Настройка) Экспорт
    Процедура ДопроведениеДокументов(Настройка) Экспорт

    Через глобальный поиск узнать откуда где эти настройки вообще могут взяться ни к чему не привело. Сколько я не работал с регламентными заданиями никогда в самой вызывающей процедуре не указывал параметр...:cool:

    Кто нибудь сталкивался с такой проблемой, или кто нибудь знает как типовые конфигурации умудряются указывать в объекте метаданных "Регламентные задания" процедуру с параметром?

    Например в конфе бухгалтерия 3.0 есть регламентное задание "ЗапускДополнительныхОбработок" которая вызывает процедуру с 2 параметрами:
    Код:
    Процедура ВыполнитьОбработкуПоРегламентномуЗаданию(ВнешняяОбработка, ИдентификаторКоманды) Экспорт...
    
  2. Dimka774
    Offline

    Dimka774

    Регистрация:
    30 июн 2016
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Тоже столкнулся с такой же проблемой. Фоном идет обмен УТ10.3 и Рт1. И тут такая проблема началась. Кто-нибудь находил решение?
  3. TopicStarter Overlay
    KilloN
    Offline

    KilloN

    Регистрация:
    17 сен 2012
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    Я поступил проще! Отредактировал Консоль заданий так, чтобы там теперь можно было указывать параметры для регламентных заданий. Добавил по 1-му параметру и все заработало!
  4. Dimka774
    Offline

    Dimka774

    Регистрация:
    30 июн 2016
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    А первый параметр это "КодНастройки"? Что это за параметр от куда его брать? Это Код узла из плана обмена?
  5. TopicStarter Overlay
    KilloN
    Offline

    KilloN

    Регистрация:
    17 сен 2012
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    Нет, это код справочника НастройкиВыполненияОбмена. Из настроек обмена удобнее всего в него заходить.

    Вложения:

  6. Dimka774
    Offline

    Dimka774

    Регистрация:
    30 июн 2016
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Дружище! Спасибо тебе огромное за помощь, сделал как ты сказал, заработало.
    Ниже прикладываю модифицированную для решения этой проблемы обработку консоли задач, может кому пригодиться.

    Вложения:

Похожие темы
  1. [GIGA]DEDUSHKA
    Ответов:
    6
    Просмотров:
    2.803
Загрузка...

Поделиться этой страницей