7.7 Регл отчетность в комплексной конфе (4002)

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем bob, 22 янв 2010.

  1. TopicStarter Overlay
    bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    НДС, раздел 3 (расчет суммы налога, подлежащей уплате в бюджет). Нет возможности заполнить автоматически. В предыдущем релизе такая возможность была. Может кто знает как заполнять, не руками же все считать...
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В комплексной раздел 3 заполняется из регистра КнигаПокупок - с ним все ок?
  3. TopicStarter Overlay
    bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    суть в том, что в последнем релизе нет кнопки "Заполнить". Посмотрел модуль отчета, там в случае комплексной конфы вообще расчет не предусмотрен. )))
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Там есть такая процедурка.....
    Код:
    Процедура УправлениеДиалогом()
    
    Форма.ВыбраннаяФирма.Видимость(1 - ПустоеЗначение(ВыбраннаяФирма));	
    
    // Форма умеет автозаполяться только в 4-х конфигурациях
    Если (ИдентКонфигурации <> "PBOUL")   // Учет и отчетность предпринимателя
    и (ИдентКонфигурации <> "BU42TK")  // Бухгалтерский учет
    и (ИдентКонфигурации <> "BUPSB25") // Производство+Услуги+Бухгалтерия
    и (ИдентКонфигурации <> "BUOUSL")  // Комплексная конфигурация 
    Тогда 
    
    // Для остальных конфигураций прячем кнопки "Заполнить" и "Расшифровать"
    Форма.Заполнить.Видимость(0);          			
    Форма.Расшифровать.Видимость(0);						
    КонецЕсли;
    
    КонецПроцедуры // УправлениеДиалогом()
    
    
    
    Разберись что у тебя с идентификатором
  5. TopicStarter Overlay
    bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    эта процедурка из релиза 4001.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да не... из четвертого пака от 19.01.10
  7. TopicStarter Overlay
    bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    что за "четвертый пак"? Сейчас скачал релиз 4003.
    Код:
    Процедура УправлениеДиалогом()
    
    Если (ИдентКонфигурации = "BUPSB25") или (ИдентКонфигурации = "BUOUSL") или (ИдентКонфигурации = "NLGPL") тогда
    Форма.Заполнить.Видимость(0);
    Форма.Расшифровать.Видимость(0);
    КонецЕсли;
    Форма.ВыбраннаяФирма.Видимость(1 - ПустоеЗначение(ВыбраннаяФирма));	
    
    КонецПроцедуры // УправлениеДиалогом()
    
    
    вобщем разработчики решили, что кто купил комплексную конфу, может себе позволить и ручками заполнить отчет :unsure:
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    General.rp09q4.GRP.1000000k.rar от 19.01.10
  9. TopicStarter Overlay
    bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    Хрен с ним с отчетом, Угодник, ты уперся в старую версию. Обнови отчетность вышла 09q4003
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    вот из 4003го. Там то условие которое я описывал

    Вложения:

    • NDS0904.ERT
      Размер файла:
      209 КБ
      Просмотров:
      23
  11. TopicStarter Overlay
    bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    NDS0904.ERT это для НДС с пометкой "Старая". Для нового отчета файл NDS904.ERT . Вобщем разработчики для комплексной пока не сделали авто заполнение отчетов.

Поделиться этой страницей