7.7 Регистр остатков

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Cooper-Mixal, 28 янв 2010.

  1. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Добрый день уважаемые коллеги!

    Имеется регистр остатков Товары.
    в нем имеется реквизит ВидДрагМеталл имеющий тип перечисление.

    Ресурсы и измерения регистра замечательно подтягиваются!

    Как мне этот реквизит из регистра подтянуть?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Через группировку в запросе
  3. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Нет, так тоже не выходит! Что с группировкой, что без - результат нулевой!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Выкладывайте запрос
  5. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Код:
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Материал                 = Регистр.Товары.Материал;
    |Склад                     = Регистр.Товары.Склад;
    |Количество             = Регистр.Товары.Количество;
    |КоличествоДраг         = Регистр.Товары.КоличествоДраг;
    |ВидДраг         = Регистр.Товары.ВидДраг;
    
    |Группировка Материал без групп упорядочить по Материал.Код;
    |Группировка Склад упорядочить по Склад.Наименование;     
    //|Группировка ВидДраг;
    |Условие(Склад в ВыбСклад);
    </span>
    |"//}}ЗАПРОС;
    // Если ошибка в запросе, то выход из процедуры
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Отчет");
    Пока Запрос.Группировка(1) = 1 Цикл
    Пока Запрос.Группировка(2) = 1 Цикл  
    //  Пока Запрос.Группировка(3) = 1 Цикл  
    
    Если Запрос.ВидДраг = Перечисление.ВидДраг.Серебро Тогда
    ПечВидДраг = "Серебро";
    ИначеЕсли Запрос.ВидДраг = Перечисление.ВидДраг.Золото Тогда
    ПечВидДраг = "Золото";   
    ИначеЕсли Запрос.ВидДраг = Перечисление.ВидДраг.Платина Тогда
    ПечВидДраг = "Платина";   
    ИначеЕсли Запрос.ВидДраг = Перечисление.ВидДраг.Родий Тогда
    ПечВидДраг = "Родий";
    КонецЕсли;
    
    Таб.ВывестиСекцию("Материал");
    
    
    КонецЦикла;  
    КонецЦикла;  
    //                КонецЦикла;
    
    
    
    Вот код, но переменная запрос.виддраг всегда пустая!
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Правильно... А ГДЕ ОБРАЩЕНИЯ К РЕСУРСАМ?????????????
    Это вам не документ.....
    Используте функцию хотя-бы по одному ресурсу и все появится
  7. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Код:
    |Функция КоличествоНачОст = НачОст(Количество); 
    |Функция КоличествоНачОстДраг = НачОст(КоличествоДраг);
    
    
    Есть там функции. Но всё равно не получается.

    КоличествоДраг показывает, а вот его ВидДраг нет!


    А так сразу в отчет вставляются ресурсы...
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А ВидДраг случайно не периодическое значение?
  9. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    нет, но имеет тип "Перечисление"

    Ещё добавлю, что в свойствах реквизита, во вкладке Дополнительно не стоит галочки "Отбор движений". Может по этому он их не видит?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Проэкспериментируй... Но не зависит... Эта галка вляет только на скорость отбора и размер файлов базы. Для еще при детализации по документам)))))))
  11. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    уже попробовал, не изменилось ничего.

    Ты прав, эта галка, это только на скорость отбора.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Попробуй группировку по товару - ее покажет?
  13. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    К сожалению не выходит!
  14. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ну как бы я бы сначала сделал так:
    Код:
    	oVT = CreateObject("ValueTable"); 
    Запрос.Unload(oVT);
    oVT.ChooseLine();
    
    
    и посмотрел бы что у нас там получается.. а вообще мне кажется, что дело в том, что нет группировки по ВидДраг в запросе..
  15. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    завтра попробую...
  16. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    всё получится ;) утро вечера мудренее

Поделиться этой страницей