8.х Регистр бухгалтерии в документе "ОказаниеУслуг"

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Ignat.fool, 25 янв 2011.

  1. TopicStarter Overlay
    Ignat.fool
    Offline

    Ignat.fool

    Регистрация:
    25 янв 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    :angry: Значиццо проблема такая: есть документ в котором с помощью переключателя отображаются в отдельном табличном поле регистр "продажи" и регистр бухгалтерии "управленческий"
    с первым все работает шоколадно - выбираешь документ из списка вверху - внизу список движений этого документа. ...а вот второй... если в регистре по выбранному документу находится лишь одна запись то все ажурно, а вот если две и больше то система выдает это--- "Ошибка SDBL Тип поля ID несовместим с типом литерала "тут цифр и букв куча(pos=143)" и на выбор завершить или перезапустить" с коллегами советовался, у них идей нет. Может тут кто поможет))) Заранее благодарен
  2. TopicStarter Overlay
    Ignat.fool
    Offline

    Ignat.fool

    Регистрация:
    25 янв 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Вот код [/code]Процедура ПриОткрытии()
    Продажи="Продажи";
    Массив=Новый Массив;
    Массив.Добавить(Тип("РегистрНакопленияСписок.Продажи"));
    НашеОписание=Новый ОписаниеТипов(Массив);
    Табполе=ЭлементыФормы.ТабличноеПоле;
    ТабПоле.ТипЗначения=НашеОписание;
    ТабПоле.СоздатьКолонки();
    ТабПоле.Значение.Отбор.Регистратор.Установить( ,Истина);
    КонецПроцедуры

    Процедура ПродажиПриИзменении(Элемент)
    Если Продажи="Продажи" Тогда
    НужныйТип=Тип("РегистрНакопленияСписок.Продажи");
    ИначеЕсли Продажи="БухУчет" Тогда
    НужныйТип=Тип("РегистрБухгалтерииСписок.Управленческий");
    КонецЕсли;

    Массив=Новый Массив();
    Массив.Добавить(НужныйТип);
    НашеОписание=Новый ОписаниеТипов(Массив);
    Табполе=ЭлементыФормы.ТабличноеПоле;
    ТабПоле.ТипЗначения=НашеОписание;
    ТабПоле.СоздатьКолонки();

    НашОтбор=ТабПоле.Значение.Отбор;
    ЗначениеОтбора=ЭлементыФормы.ДокументСписок.ТекущаяСтрока;

    НашОтбор.Регистратор.Установить(ЗначениеОтбора ,Истина);

    КонецПроцедуры

    Процедура ДокументСписокПриАктивизацииСтроки(Элемент)
    НашОтбор=ЭлементыФормы.ТабличноеПоле.Значение.Отбор;
    Если Элемент.ТекущиеДанные=Неопределено Тогда
    НашОтбор.Регистратор.Установить( ,Истина);
    Иначе
    НашОтбор.Регистратор.Установить(Элемент.ТекущаяСтрока, Истина);
    КонецЕсли;

    КонецПроцедуры
    Код:
    
    
  3. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Ignat.fool, версию платформы скажите.

Поделиться этой страницей