7.7 реестр информационных баз

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем morsh-irina, 30 июл 2008.

  1. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    необходимо создать реестр информационных баз, при этом есть список информационных баз и список пользователей. Нужна прграмма, которая бы позволяла пользователям подключаться к списку информационных баз, либо локально, либо на сервере.
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    чет я не догдал чего ты хочешь... подключай, и пускай пользуются :) если баз много и прописать их надо много где, то лучше сначала создай файл реестра...
  3. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    А ты можешь подсказать,как создать файл реестра?
  4. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\Titles]
    "\\\\SQLSERV\\Bases\\DB-NEW\\"="Московская База"
    "\\\\SQLSERV\\Bases\\Branch-Piter\\"="База Санкт-Петербург"

    это текст моего файла реестра... ну только разве что там баз больше :) файл имеет расширение reg
  5. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1

    Спасибо тебе огромное!!!!!! :unsure:
  6. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    у меня есть батник, который сохраняет в е пути баз в текстовый файл, а второй батник прописывает базы, беря данные из этого файла. Если не разобрались, сигнализируйте, выложу.
  7. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Разобралась на 50%.Мне было бы интересно посмотреть то, что вы предлагаете
  8. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    пожалуйста!

    Вложения:

  9. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Спасибо!
    А можешь листинг прислать? :unsure:
    И какая функция/процедура необходима в 1С чтобы можно было прочитать/считать из файла?
  10. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    не понял....
    в 1С не надо ничего, оно отдельно работает, запускаешь, формируется файл текстовый с путями баз, запускаешь, прописываются пути баз в реестр. Запуск там с разными ключами. (см ридми.тхт)
  11. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Я поняла как работает твоя программа,я не поняла, как ты ее написал. :unsure:
  12. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    я ее не писал :unsure:
  13. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    morsh-irina, если хорошо еще раз прочитаешь ветку, то принцип работы поймешь.
    Если не поймешь принцип работы, то листинг программы тебе ничего не даст.
  14. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Прошу вас,кто-нибудь,подскажите...
    Необходимо написать программу,которая должна выполнять подключение пользователей к информационным базам,т.е. я на своем компьютере запускаю программу,а на комьютере у другого пользователя открывается нужная ему информационная база.
    Ниже моя программа, в которой не хватает именно подключения пользователя к инфо базе. Т.е выводятся все пользователи из справочника пользователей, таким же образом выводятся инфо базы, выбираю пользователя,выбираю базу. А как подключить их не знаю. Надеюсь кто-нибудь откликнеся,если знает как дописать эту программу. :unsure:

    Код:
    //*********-Моя программа-***********
    Перем ТекстФайла;
    Перем Сч; 
    Перем Текст; 
    Перем ВыбЗнач; 
    Перем Табл;
    Перем Спр;
    Перем Пользов; 
    Перем Парам; 
    Перем Знч; 
    Перем СпособВыборкиПользователей;
    Перем ВыбранноеПодразделение; 
    Перем СпрПользователи; 
    Перем ВыбПодразделение;
    Перем ВыбПользователь; 
    Перем Символ, Стр, Сч1, Сч2;
    
    //------------------------------------------------------------------------------ 
    Процедура ПриОткрытии() 
    
    ЗапуститьПриложение(КаталогИБ() + "PL1CConfReg.exe /exp");
    ЗапуститьПриложение(КаталогИБ() + "StartUp.");
    //Combobux вывести всех пользователей из справочника пользователей
    
    
    Спр = СоздатьОбъект("Справочник.Пользователи");
    
    // Польз.УдалитьВсе();
    Спр.ВыбратьЭлементы();
    
    Пока Спр.ПолучитьЭлемент() > 0 Цикл 
    Пользов = Спр.Наименование;
    // Польз.ДобавитьЗначение(Пользов); 
    КонецЦикла; 
    
    ///=================================================================
    
    // Символ = "лололожр";
    
    
    // Для Сч = 2 по СтрДлина(Стр) Цикл
    // 
    // Если Символ = " " Тогда
    // Возврат;
    // КонецЕсли; 
    
    // Сч1 = Сч1 + 1;
    // Сообщить(Символ);
    // Символ=Сред(Стр,Сч,1); 
    
    // КонецЦикла; 
    
    // Сообщить(Сч1); 
    ///================================================================= 
    КонецПроцедуры 
    
    //------------------------------------------------------------------------------
    Процедура Сформировать() 
    
    
    Если ФС.СуществуетФайл(КаталогИБ() + "Titles.ini") = 1 Тогда 
    
    ТекстФайла = СоздатьОбъект("Текст"); 
    ТекстФайла.Открыть(КаталогИБ() + "Titles.ini"); 
    ИнфБазы.УдалитьВсе();
    
    
    Для Сч=1 по ТекстФайла.КоличествоСтрок() Цикл
    
    Текст = ТекстФайла.ПолучитьСтроку(Сч); 
    
    Если (Лев(Текст,9) = "Загрузить") или (Лев(Текст,9) = "[Software") тогда
    Продолжить;
    КонецЕсли;
    
    
    Для Сч1 = 1 по СтрДлина(Текст) Цикл
    
    Символ=Сред(Стр,СтрДлина(Текст)-Сч1+1,1); 
    
    Если Символ = "" Тогда
    Возврат;
    КонецЕсли; 
    
    Сч2 = Сч2 + 1; 
    КонецЦикла; 
    
    
    ИнфБазы.ДобавитьЗначение(Прав(Текст,Сч2)); 
    
    КонецЦикла;
    КонецЕсли; КонецПроцедуры 
    //------------------------------------------------------------------------------
    Процедура Заполнить()
    
    Спр = СоздатьОбъект("Справочник.Пользователи");
    Спр.ВыбратьЭлементы();
    
    Список = СоздатьОбъект("СписокЗначений");
    // Список.ДобавитьЗначение(Знч);
    ОткрытьФорму("Справочник.Пользователи", Список); 
    
    КонецПроцедуры 
    
    Процедура Запустить_Приложение()
    
    перем Текст_Файла;
    Если ПустоеЗначение("ИнфоБазы") = 1 Тогда
    Сообщить("Выберите информационную базу");
    КонецЕсли;
    Если ПустоеЗначение("ВыбПользователя")=1 Тогда
    Сообщить("Выберите пользователя");
    КонецЕсли; 
    
    
    
    Текст_Файла = СоздатьОбъект("Текст");
    
    Текст_Файла.ДобавитьСтроку("Windows Registry Editor Version 5.00");
    Текст_Файла.ДобавитьСтроку("");
    Текст_Файла.ДобавитьСтроку("[HKEY_CURRENT_USERSoftware1C1Cv77.7Titles"+ИнфБазы+"StartUp]");
    //Текст_Файла.ДобавитьСтроку("""+"UserName"=""+ВыбПользователя+""");
    //Текст_Файла.ДобавитьСтроку("");
    
    Текст_Файла.Записать(КаталогИБ()+"Выгрузка.reg");
    
    ЗапуститьПриложение(КаталогИБ() + "Выгрузка.reg"); 
    КонецПроцедуры 
    
    :smile:

Поделиться этой страницей