7.7 Реестр документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Pupsa, 6 авг 2008.

  1. TopicStarter Overlay
    Pupsa
    Offline

    Pupsa

    Регистрация:
    6 авг 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Уважаемые форумчане! Помогите начинающему программисту дописать отчет. Необходимо вывести реестр документов(расходнаяНакладная и АктВыпРабот) за период по филиалу и складу.
    Делаю запросом по расходной накладной, все нормально, выводит так как надо. Пытаюсь организовать запрос по двум документам выводит опять же только расходные накладные, а по актам сверки полный игнор. Посмотрите пожалуйста может у кого какие идеи есть или я что неправильно делаю???
    Код:
    //*******************************************
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем ТФирма;  </span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем ТСклад;</span>
    Процедура Сформировать()   
    ДокП = СоздатьОбъект("Документ");
    Запрос  = СоздатьОбъект("Запрос");
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");  
    Таб.ВывестиСекцию("Строка");
    Таб.ВывестиСекцию("Строка1");
    Таб.ВывестиСекцию("Строка3");
    ТЗ  = СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Вид");
    ТЗ.НоваяКолонка("Номер");
    ТЗ.НоваяКолонка("Получатель");
    ТЗ.НоваяКолонка("РНН");
    ТЗ.НоваяКолонка("НомСЧФ");
    ТЗ.НоваяКолонка("НомРН");
    ТЗ.НоваяКолонка("Дата");
    ТЗ.НоваяКолонка("БезНДС");
    ТЗ.НоваяКолонка("НДС");
    ТЗ.НоваяКолонка("Сумма");
    ТЗ.НоваяКолонка("Фирма"); 
    ТЗ.НоваяКолонка("НомерДок");
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = " 
    |Период с Дата1 по Дата2;
    |ОбрабатыватьДокументы Проведенные;
    |Док   = Документ.РасходнаяНакладная.ТекущийДокумент,Документ.АктВыпРабот.ТекущийДокумент;
    |Фирма = Документ.РасходнаяНакладная.Фирма,Документ.АктВыпРабот.Фирма;  
    |СуммаБезНДС = Документ.РасходнаяНакладная.СуммаБезНДС,Документ.АктВыпРабот.СуммаБезНДС;
    |НДС = Документ.РасходнаяНакладная.НДС,Документ.АктВыпРабот.НДС;
    |Сумма = Документ.РасходнаяНакладная.Сумма,Документ.АктВыпРабот.Сумма;
    |ТСклад = Документ.РасходнаяНакладная.МестоХранения;
    |Условие(ТСклад в Склад); 
    |Группировка ТСклад;
    |Группировка Док;"; 
    ;
    Если РазделительУчета.Выбран() = 1 Тогда
    ТекстЗапроса = ТекстЗапроса + "
    |Условие(Фирма = РазделительУчета);";
    КонецЕсли; 
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Сообщить("Ошибка выполнения запроса!","!");
    Возврат;
    КонецЕсли;
    Номер = 1;
    Пока Запрос.Группировка(1) = 1 Цикл  
    Пока Запрос.Группировка(2) = 1 Цикл 
    тз.НоваяСтрока(); 
    Док = Запрос.Док;
    тз.Получатель = Запрос.Док.Получатель;
    тз.РНН = Запрос.Док.Получатель.РНН;
    тз.НомРН = Запрос.Док.НомерДок;
    тз.Дата = Запрос.Док.ДатаДок;
    тз.БезНДС = Запрос.СуммаБезНДС;
    тз.НДС = Запрос.НДС;
    тз.Сумма = Запрос.Сумма;
    Номер = Номер + 1;
    КонецЦикла; 
    КонецЦикла;
    тз.ВыбратьСтроки();
    Пока тз.ПолучитьСтроку()=1 Цикл
    Таб.ВывестиСекцию("Строка2");
    КонецЦикла; 
    ИтогБезНДС = ТЗ.Итог("БезНДС");
    ИтогНДС = ТЗ.Итог("НДС"); 
    ИтогСумма = ТЗ.Итог("Сумма");
    Таб.ВывестиСекцию("Строка4");
    Таб.ТолькоПросмотр(1); 
    Таб.Опции(0,0,0,0);
    Таб.Показать();
    КонецПроцедуры
    
  2. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Посмотрите первую группировку, данные группируются по значениям складов только из расходной накладной, понятно что и акт сверки в эту группировку не попадает.
Похожие темы
  1. Zara
    Ответов:
    9
    Просмотров:
    3.339
  2. Lourens
    Ответов:
    6
    Просмотров:
    1.724
Загрузка...

Поделиться этой страницей