7.7 Реестр для сбербанка.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем roalang, 21 май 2013.

  1. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Имелось ввиду наверное это?
    Код:
    Код = СтрПолучитьСтроку(Стр1,2);
  2. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Большое спасибо за помощь.
    Скажите пожалуйста можно ли изменить текущую колонку в табличной части документа. При загрузки реестра в документ платежек текущей получается колонка НомерСтроки, а мне надо чтобы была текущий следущая колонка ЛицСчет.
  3. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Сама нашла.
    При сохранении файла для сбербанка перед перед расширением создается 8 пробелов, т.е. <TC124568 .446> Как их можно убрать


    Код:
    ДД = Строка(ДатаЧисло(РабочаяДата()));
    ММ = Строка(ДатаМесяц(РабочаяДата()));
    Y = Прав(Строка(ДатаГод(РабочаяДата())),1);
    ИмяФайла = "TC"+
    ?(СтрДлина(ДД)=2,ДД,"0"+ДД)+
    ?(СтрДлина(ММ)=2,ММ,"0"+ММ)+
    Y+Строка(НомРеестр)+".446";
    Попытка
    ФС.КопироватьФайл("c:\реестрСБ_КВ\temp.txt","c:\реестрСБ_КВ\"+ИмяФайла,0);
    Исключение
    КонецПопытки;
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Можно проще
    Код:
    ИмяФайла=Формат(РабочаяДата(),"Д(0)ДДММГГ");
    ИмяФайла=Лев(ИмяФайла,2)+Сред(ИмяФайла,4,2)+Прав(ИмяФайла,1)+СокрЛП(НомРеестр)+".446";
    
  5. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Здравствуйте.
    А так не проще?
    Код:
    ИмяФайла = "ТС"+СтрЗаменить(Формат(РабочаяДата(),"ДДДММГГ"),".","")+СокрЛП(НомРеестр)+".446";
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не совсем так. Вы не внимательны. год - одна цифра
  7. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Здравствуйте.
    Одна цифра года - это требование Сбербанка? Странно. Обычно бывает две или четыре.
    Вы, кстати, сами пропустили начальное "ТС".
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да.

    Бог его знает. Наверное, судя по коду.
  9. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Да требования у сбербанка такие.
  10. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Тогда уже не так просто получается.

    Код:
    ДатаСтр = СтрЗаменить(Формат(РабочаяДата(),"ДДДММГГ"),".","");
    ИмяФайла = "ТС"+Лев(ДатаСтр,4)+Прав(ДатаСтр,1)+СокрЛП(НомРеестр)+".446";
  11. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Скажите пожалуйста как сделать, что бы выгрузка была формата:
    #Filesum <Сумма>
    #Type 7
    #Service <Код услуги>
    <ФИО; Адрес;лицевой счет; сумма >.
    Как сделать чтобы первые три строки начинались с новой строки.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Используйте объект текст
    Код:
    Т=СоздатьОбъект("Текст");
    Т.ДобавитьСтроку("Привет от тети Моти!");
    Т.ДобавитьСтроку(" и еще один привет!");
    Т.Записать("ВашеИмя");
  13. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Совсем запуталась (. Как сделать чтобы первые три строчки были только в начале файла. Я сделала, так чтобы после каждой строки с ФИО были, а надо только один раз.
    Код:
     тхт = СоздатьОбъект("Текст");
    тхт1 = СоздатьОбъект("Текст");   
    тхт1.ДобавитьСтроку("#FILESUM "); 
    тхт1.ДобавитьСтроку("#TYPE 7");
    тхт1.ДобавитьСтроку("#Service ");
    тхт1.Записать("c:\кбб\temp1.txt");
    
    ТР.Свернуть("Код,ФИО,Адрес,КодУсл,Услуга,Период,ЕМР6,ЕМР7,ЕМР8","Сумма");
    ТР.ВыбратьСтроки();
    Пока ТР.ПолучитьСтроку()=1 Цикл 
    
    тхт1.Открыть("c:\кбб\temp1.txt");   
    
    Для н = 1 По тхт1.КоличествоСтрок() Цикл
    стр1 = тхт1.ПолучитьСтроку(н);
    КодКв = Нрег(СокрЛП(ТР.Код));
    
    //КодКв=Замена(КодКв);  
    //КодКв=Замена1(КодКв);
    //КодКв=Замена2(КодКв);
    
    итог = ТР.Итог("Сумма") ;
    
    Если стр1 = "#FILESUM " тогда Стр2 = стр1 + итог ;
    иначеесли стр1 = "#TYPE 7" тогда Стр3 = Стр1 ;
    иначеесли стр1 = "#Service "  тогда Стр4 = стр1 + ТР.КодУсл ;
    конецесли;
    
    КонецЦикла;
    тхт.Добавитьстроку(Стр2);
    тхт.Добавитьстроку(Стр3);
    тхт.Добавитьстроку(Стр4);
    
    Стр = "";  
    СтрФИО = СтрЗаменить(ТР.ФИО,"/"," ");  
    Стр = Стр + СокрЛП(СтрФИО) + ";";
    Стр = Стр + СокрЛП(ТР.Адрес) + ";"; 
    Стр = Стр + КодКв + ";";  
    Стр = Стр + ТР.Сумма + ";";
    Стр = Стр + ТР.КодУсл + ";";
    Стр = Стр + ";";	
    Стр = Стр + ";";	
    Стр = Стр +  ";";	
    Стр = Стр + ТР.Период + ";";
    
    
    тхт.Добавитьстроку(Стр);   
    
    КонецЦикла; 
    тхт.Добавитьстроку("");	
    тхт.КодоваяСтраница(1);
    
    тхт.Записать("c:\кбб\temp.txt");
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    ТР.ПолучитьСтрокуПоНомеру(1);
    тхт = СоздатьОбъект("Текст");
    тхт.ДобавитьСтроку("#FILESUM "+ТР.Итог("Сумма"));
    тхт.ДобавитьСтроку("#TYPE 7");
    тхт.ДобавитьСтроку("#Service "+ТР.КодУсл);
    
    ТР.Свернуть("Код,ФИО,Адрес,КодУсл,Услуга,Период,ЕМР6,ЕМР7,ЕМР8","Сумма");
    ТР.ВыбратьСтроки();
    Пока ТР.ПолучитьСтроку()=1 Цикл
    
    Стр = СтрЗаменить(ТР.ФИО,"/"," ")+ ";";
    Стр = Стр + СокрЛП(ТР.Адрес) + ";";
    Стр = Стр + Нрег(СокрЛП(ТР.Код)) + ";";  
    Стр = Стр + ТР.Сумма + ";";
    Стр = Стр + ТР.КодУсл + ";";
    Стр = Стр + ";";	
    Стр = Стр + ";";	
    Стр = Стр +  ";";	
    Стр = Стр + ТР.Период + ";";
    
    
    тхт.Добавитьстроку(Стр);  
    
    КонецЦикла;
    тхт.Добавитьстроку("");	
    тхт.КодоваяСтраница(1);
    
    тхт.Записать("c:\кбб\temp.txt");
    
  15. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Спасибо всех за помощь! Все работает.
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  17. Неназываемый
    Offline

    Неназываемый Опытный в 1С Команда форума

    Регистрация:
    2 фев 2007
    Сообщения:
    507
    Симпатии:
    7
    Баллы:
    29

    Лучше поздно чем никогда.
    А плюсик я сам ткну угоднику :D
  18. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Добрый день. Скажите можно ранее сохраненный реестр, открыть и дописать туда еще строчки?
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей