7.7 Редактирование записи в справочнике

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем compozitor, 5 фев 2010.

  1. TopicStarter Overlay
    compozitor
    Offline

    compozitor

    Регистрация:
    24 янв 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста!
    Пишу функцию редактирования записи справочника.
    Для редактирования вызываю форму элемента справочника.
    Никак не могу правильно написать процедуру проверки на совпадение.
    Уникальное поле арт.
    Вот код:
    Код:
    Процедура ПриЗаписи()
    спр=СоздатьОбъект("Справочник.Стоимость_Сборки");
    Если спр.НайтиПоРеквизиту("арт",арт,1)=1 тогда  	
    Предупреждение("Запись: "+арт+" уже существует!");
    арт="";   	
    СтатусВозврата(0);   	
    Возврат;  
    КонецЕсли;     
    КонецПроцедуры
    
    При отрабатывании данной процедуры, если я не меняю поле арт появляется предупреждения,что такая запись уже существеэт. Мне нужно чтобы запись которую я редактирую не включалась в область проверки на совпадение(область перебора записей справочника).
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура ПриЗаписи()
    спр=СоздатьОбъект("Справочник.Стоимость_Сборки");
    Если спр.НайтиПоРеквизиту("арт",арт,1)=1 тогда  
    Если Спр.ТекущийЭлемент()<>ТекущийЭлемент() Тогда    
    Предупреждение("Запись: "+арт+" уже существует!");
    арт="";       
    СтатусВозврата(0);       
    Возврат;  
    КонецЕслИ;
    КонецЕсли;     
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    compozitor
    Offline

    compozitor

    Регистрация:
    24 янв 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    :unsure: Большое спасибо!!! Очень помогло.

Поделиться этой страницей