[РЕШЕНО] Редактирование реквизитов справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем darkghostnt, 24 апр 2014.

  1. TopicStarter Overlay
    darkghostnt
    Offline

    darkghostnt

    Регистрация:
    24 апр 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ ДокТалон.ВремяПриёма КАК Время
    |ИЗ
    | Документ.Талон КАК ДокТалон
    |ГДЕ ДокТалон.ФИОВрача = &Врач И ДокТалон.ДатаПриема = &ДатаПриема";
    Запрос.УстановитьПараметр("Врач", ЭлементыФормы.Врач.Значение);
    Запрос.УстановитьПараметр("ДатаПриема", ЭлементыФормы.ДатаПриема.Значение);
    
    Результат = Запрос.Выполнить().Выбрать();
    Выбранные.Очистить();
    Пока Результат.Следующий() > 0 ЦИКЛ
    //Проверка результата запроса - работает
    Выбранные.Добавить("Время приема "+Строка(Результат.Время));
    
    Запрос2 = новый запрос;
    Запрос2.Текст = "ВЫБРАТЬ Смена.Код КАК Код
    |ИЗ
    | Справочник.Смена КАК Смена
    |ГДЕ Смена.Время = &Время";
    Запрос2.УстановитьПараметр("Время", Результат.Время);
    
    Рез = Запрос2.Выполнить().Выбрать();
    Пока Рез.Следующий() > 0 ЦИКЛ
    //Проверка результата запроса - работатет
    Отбор.Добавить(Строка(Рез.Код));
    //Как по коду строки в Справочнике поменять реквизит?
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры

    Вложения:

    • Обраб.jpg
      Обраб.jpg
      Размер файла:
      142,6 КБ
      Просмотров:
      8
    Последнее редактирование модератором: 25 апр 2014
  2. TopicStarter Overlay
    darkghostnt
    Offline

    darkghostnt

    Регистрация:
    24 апр 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Код:
    ***
    Пока Рез.Следующий() > 0 ЦИКЛ
    //Проверка результата запроса - работатет
    Выб = Справочники.Смена.НайтиПоКоду(Рез.Код);
    Объект = Выб.ПолучитьОбъект();
    Объект.Занято = Истина;
    Объект.Записать();
    КонецЦикла;
    Последнее редактирование модератором: 25 апр 2014

Поделиться этой страницей