8.х редактирование ячейки дерева значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем leha, 1 ноя 2010.

  1. TopicStarter Overlay
    leha
    Offline

    leha

    Регистрация:
    9 июн 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Помогите разобраться или средиректите на решение проблемы - не могу найти решения.

    Задача.
    На форме имеем Таблицу Значений с типом "СправочникСписок.Номенклатура". Таблица есть в реквизитах формы. В эту таблицу добавлена колонка Сумма. По сути, мне надо заполнить руками значения ячеек колонки "Сумма" для номенклатурных групп, чтобы в дальнейшем использовать эти значения для расчетов.

    Если ли возможность редактировать значения в ячейках колонки "Сумма"? Или же в описанном случае колонка "Сумма" является только элементом формы?
    Какие есть пути решения этой задачи?
  2. Доктор Руфус Бейли
    Offline

    Доктор Руфус Бейли Опытный в 1С

    Регистрация:
    7 апр 2010
    Сообщения:
    277
    Симпатии:
    0
    Баллы:
    26
    В своё время я решил схожую задачку следующим образом.

    Код:
    Процедура ДокументСписокПередНачаломИзменения(Элемент, Отказ)
    Колонка = ЭлементыФормы.ДокументСписок.ТекущаяКолонка;
    Строка = ЭлементыФормы.ДокументСписок.ТекущаяСтрока;
    Если НЕ Колонка.Имя = "ОплатаГрузчику" Тогда
    Форма = Строка.Ссылка.ПолучитьФорму();
    Форма.Открыть();
    Иначе
    Отказ = Истина;
    Объект = Строка.Ссылка.ПолучитьОбъект();
    Если ВвестиЧисло(Объект.ОплатаГрузчику, "Введите оплату грузчику") Тогда
    Объект.УдельнаяСтоимостьПеревозкиРасчётная = (Объект.ОплатаГрузчику + Объект.ОплатаВодителюРасчётная)/Объект.ТоннажРейса;
    Объект.УдельнаяСтоимостьПеревозкиФактическая = (Объект.ОплатаГрузчику + Объект.ОплатаВодителюФактическая)/Объект.ТоннажРейса;
    Объект.Записать();
    КонецЕсли;	
    КонецЕсли;
    КонецПроцедуры
    
  3. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    А какой тип поля Сумма?
  4. TopicStarter Overlay
    leha
    Offline

    leha

    Регистрация:
    9 июн 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Числовой. Поэтому хотелось бы редактировать без диалога.
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Сделайте поле ввода.
  6. TopicStarter Overlay
    leha
    Offline

    leha

    Регистрация:
    9 июн 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Я делаю поле ввода, но опять же при даблклике по ячейки у меня происходит открытие иерархии.
    Сделав обработчик ПередНачаломИзменения как советовал Доктор Руфус Бейли, я получил возможность ввести значение. Но имею две проблемы:
    1. пока не доганю куда сохранять результат (чёт тупняк напал жёсткий)
    2. эта возможность появляется не по даблклику по ячейки, а только если правой кнопкой на ячейки вызвать меню и выбрать там "Редактирование", что конечно в работе пользователям будет не очень удобно.

Поделиться этой страницей