7.7 Редактироване формы инв-3 инв-19.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Werdik, 23 окт 2012.

  1. TopicStarter Overlay
    Werdik
    Offline

    Werdik

    Регистрация:
    23 окт 2012
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Скажите как убрать из формы строки с нулевым значением?

    по модулю инв-3, что добавить чтоб не выводить?

    Код:
    Если ВидТМЦ = 3 Тогда // инвентаризация розничной точки
    Сумма	 = Количество * Цена;
    СуммаУчет = КоличествоУчет * Цена;
    КонецЕсли;
    ИтогСуммаОпись	= ИтогСуммаОпись + Сумма;
    ИтогКоличОпись	= ИтогКоличОпись + Количество;
    ИтогСуммаСтраница = ИтогСуммаСтраница + Сумма;
    ИтогКоличСтраница = ИтогКоличСтраница + Количество;
    ИтогСуммаУчетОпись	= ИтогСуммаУчетОпись + СуммаУчет;
    ИтогКоличУчетОпись	= ИтогКоличУчетОпись + КоличествоУчет;
    ИтогСуммаУчетСтраница = ИтогСуммаУчетСтраница + СуммаУчет;
    ИтогКоличУчетСтраница = ИтогКоличУчетСтраница + КоличествоУчет;


    инв-19

    Код:
    Если Количество > КоличествоУчет Тогда
    Излишек	  = Количество   - КоличествоУчет;
    СуммаИзлишек = СуммаФактПеч - СуммаУчетПеч;
    
    ИтогИзлишек		= ИтогИзлишек	  + Излишек;
    ИтогСуммаИзлишек   = ИтогСуммаИзлишек + СуммаИзлишек;
    
    Недостача	  = 0;
    СуммаНедостача = 0;
    
    ИначеЕсли КоличествоУчет > Количество Тогда
    Недостача	  = КоличествоУчет - Количество;
    СуммаНедостача = СуммаУчетПеч   - СуммаФактПеч;
    
    ИтогНедостача	  = ИтогНедостача	  + Недостача;
    ИтогСуммаНедостача = ИтогСуммаНедостача + СуммаНедостача;
    
    Излишек	  = 0;
    СуммаИзлишек = 0;
    Иначе
    Продолжить;
    КонецЕсли;
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Судя по условиям - нулевые строки не должны выводится.
  3. TopicStarter Overlay
    Werdik
    Offline

    Werdik

    Регистрация:
    23 окт 2012
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    выводяться строки с 0. их очень много. отчёт на страниц.

    какое уловие можно добавить на проверку "0" и при совпадении перехода к новой строке?

    что за переменная? -
    Код:
    [b]ИтогКоличОпись[/b] = [b]ИтогКоличОпись [/b]+ Количество;
    и что это тогда? -
    Код:
    ИтогКоличОпись = ИтогКоличОпись + [b]Количество[/b];
    в 1с я не силён. Думал может так -
    Код:
     КонецЕсли;
    [b]Если ИтогКоличОпись = 0 Тогда
    ?????????[/b]
    [b]КонецЕсли[/b]
    ИтогСуммаОпись = ИтогСуммаОпись + Сумма;
    ИтогКоличОпись = ИтогКоличОпись + Количество;
    аналогично в инв-19 -
    Код:
    [b]Если Количество = 0 КоличествоУчет = 0 Тогда[/b]
    [b]????????????[/b]
    [b]КонецЕсли[/b]
    Если Количество > КоличествоУчет Тогда
    Излишек   = Количество   - КоличествоУчет;
    СуммаИзлишек = СуммаФактПеч - СуммаУчетПеч;
    Но дальше застрял.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Хорошо. Зайдем с другого конца. Покажите где именно у вас нули. Сформируйте и прикрепите к сообщению форму
  5. TopicStarter Overlay
    Werdik
    Offline

    Werdik

    Регистрация:
    23 окт 2012
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
  6. TopicStarter Overlay
    Werdik
    Offline

    Werdik

    Регистрация:
    23 окт 2012
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    судя по скрину вы делаете ИНВ-3 и сверку наличия. Код же привели из ИНВ-19. Там как раз нулевые и не выводятся.

    1) В процедуре ПечатьИнвОписи()
    Код:
    //кусок кода для "привязки" по месту
    Если ВидТМЦ = 3 Тогда // инвентаризация розничной точки
    Иначе
    Цена = ?(Количество <> 0, Сумма/Количество, Сумма);
    КонецЕсли;
    
    //а вот это мы добавили
    Если (КоличествоУчет=0)И(Количество=0) Тогда
    Продолжить;
    КонецЕсли;
    
    2) В процедуре ПечатьСверкиНаличия()

    Код:
    //кусок кода для "привязки" по месту
    
    Ном = 0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    
    //а вот это мы добавили
    Если (КоличествоУчет=0)И(Количество=0) Тогда
    Продолжить;
    КонецЕсли;
    
  8. TopicStarter Overlay
    Werdik
    Offline

    Werdik

    Регистрация:
    23 окт 2012
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Бухгалтерский угодник спасибо, всё сработало. Хороший форум. В закладки.
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь.

Поделиться этой страницей