7.7 Ребят помогите Код элемента справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Kyznets, 24 янв 2010.

  1. TopicStarter Overlay
    Kyznets
    Offline

    Kyznets Опытный в 1С

    Регистрация:
    24 янв 2010
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Ребят помогите. Вот смотрите есть Код элемента справочник он генерируется автоматически при создании номенклатуры. Я в редакторе форм Номенклатуры добавил поле НомерТовара мне нужно чтоб там генерировался числовой код заданным мной длины при создании номенклатуры как и Код элемента справочник.
    Подскажите где Находиться алгоритм генерации Кода элемента справочник. Я чего то не найду его :unsure:
    ТиС 1с v7.7
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Это стандартный механизм, который работает только для кода, если это справочник или для номера, если это документ. Во всех остальных случаях нумератор пишите сами.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Если НомерТовара д.б. отличен от кода товара - воспользуйтесь генератором случайных чисел

    Код:
    Перем GlSeed;
    
    Функция СлучайноеЧисло(N)
    m35=34359738368;
    m36=68719476736;
    m37=137438953472;
    GlSeed=5*GlSeed;
    Если GlSeed>=m37 Тогда GlSeed=GlSeed-m37 КонецЕсли;
    Если GlSeed>=m36 Тогда GlSeed=GlSeed-m36 КонецЕсли;
    Если GlSeed>=m35 Тогда GlSeed=GlSeed-m35 КонецЕсли;
    Возврат Цел(GlSeed/m35*N)+1;
    КонецФункции
    
    
    Добавьте только проверу на длину числа и добавление лидирующих нулей если НомерТовара строка
  4. TopicStarter Overlay
    Kyznets
    Offline

    Kyznets Опытный в 1С

    Регистрация:
    24 янв 2010
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    О спасиб попробую.

Поделиться этой страницей