7.7 Разнос пробега

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Almius, 2 авг 2007.

  1. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Стояла у меня задача разнести месячный пробег автомобилей на первое число каждого месяца. сделал следущим образом: Процедура РозносПроб2 ()
    Подскажите как разнести пробег на каждый день.
    Каждый день в док."ПутевыеЛистыАвт" вносятся СпидомНач и СпидомКон. так же вносится дата. Для каждой машины свой документ. Подскажите плиз как сделать а то зашел в тупик :unsure:

    Процедура РозносПроб2 ()

    Тр=СоздатьОбъект("Справочник.Транспорт");
    Док=СоздатьОбъект("Документ");
    Тр.ВыбратьЭлементы();
    Пока Тр.ПолучитьЭлемент() = 1 Цикл
    Док.ВыбратьПоЗначению(Дата1,Дата2,"ТрСредство",Тр.ТекущийЭлемент());
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если (Док.Вид()="ПутевыеЛистыАвт") Тогда
    МесПроб=Док.Итог("СпидомКон")-Док.Итог("СпидомНач");
    Сообщить(""+Док+" "+Док.ТрСредство+" "+МесПроб);
    НачПроб= Тр.НачПроб.Получить(Дата1) ;
    Тр.НачПроб.Установить(Дата2+1,НачПроб+МесПроб);
    Тр.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
  2. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Никто не понял вопроса или просто незнает :unsure: ?
    Подскажите плиз как реализовать
  3. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Вообще не могу разобрать что ты делаешь...
    Надо занести данные в справочник?
  4. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Есть справочник "Транспорт" в нем есть периодический реквизит "НачПроб"
    был раставлен начальный пробег на 1 января, после чего сделана обработка "Процедура РозносПроб2 ()" этим мы получили пробег автомобиля на первое число каждого месяца. после чего стала задача как расчитать пробег на каждый день месяца.
    Данные брались из документа "ПутевыеЛистыАвт" в который ежедневно вносятся данные СпидомНач и СпидомКон.

    попробывал так но что то не идет так как надо

    Процедура РозносПроб3 ()

    Тр=СоздатьОбъект("Справочник.Транспорт");
    Док=СоздатьОбъект("Документ");

    Тр.ВыбратьЭлементы();
    Пока Тр.ПолучитьЭлемент() = 1 Цикл
    Док.ВыбратьПоЗначению(Дата1,Дата2,"ТрСредство",Тр.ТекущийЭлемент());
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если (Док.Вид()="ПутевыеЛистыАвт") Тогда
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    ДнПроб=Док.СпидомКон-Док.СпидомНач;
    Сообщить(""+Док+" "+Док.ТрСредство+" "+ДнПроб);
    НачПроб= Тр.НачПроб.Получить(Дата1);
    Тр.НачПроб.Установить(Док.ДатаОбр,НачПроб+ДнПроб);
    Тр.Записать();

    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
  5. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    А теперь для полного счастья - структуру документа "Путевой лист". Как часто он заносится и что в строках?
  6. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Если ПутевойЛист каждый день заводиться, то и расчитывай пробег из документа напрямую, на каждый день.
  7. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    На одну машину в начале месяца заводится один документ и все данные каждый день в носятся в него в документе 30 записей.


    Заносятся данные ежедневно. На один автомобиль один документ.

    основные реквизиты которые нас интересуют это "датаОбр" - (это дата на которую заносятся) "СпидомНач" "СпидомКон"
  8. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Нужно получить пробег каждого автомобиля за день? Тогда перебирай документ построчно и считай значения.
    Не очень внимательно ветку просмотрел, сорри. В принципе у тебя в листинге идея верная. Но лучше запросом сделать, быстрее будет.
Похожие темы
  1. quadros
    Ответов:
    2
    Просмотров:
    1.314
  2. dlis
    Ответов:
    11
    Просмотров:
    446
Загрузка...

Поделиться этой страницей