7.7 Разнос остатков

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем quadros, 30 май 2007.

  1. TopicStarter Overlay
    quadros
    Offline

    quadros

    Регистрация:
    21 май 2007
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Всем доброго дня.
    Подскажите пожалуйста.

    Имеется справочник "каталог номер" подчиненный справочнику "материалы". В справочнике "каталог номер" реквизит "кол" тип переодический как перебрать все документы расхода и прихода чтобы записать в справочник "каталог номер" движения/остатки по каждому кат номеру.

    Разнос остатков из карточек делал следующим образом:

    Процедура РазносОст ()
    Док = СоздатьОбъект("Документ.Карточка");
    Мат = СоздатьОбъект("Справочник.Материалы");
    КатНом = СоздатьОбъект("Справочник.КаталогНомер");
    Док.ВыбратьДокументы(НачГода(РабочаяДата()),'31.12.07') ;

    Пока Док.ПолучитьДокумент()=1 Цикл
    Сообщить(""+Док);
    КатНом.ИспользоватьВладельца(Док.Карточка);
    Док.ВыбратьСтроки() ;
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если КатНом.НайтиПоНаименованию(Док.КаталожнНом,1)=1 Тогда
    КатНом.Кол.Установить(Док.ДатаДок,Док.Количество);
    Сообщить("Номер уже существует "+Док.КаталожнНом);
    КонецЕсли;

    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
  2. TopicStarter Overlay
    quadros
    Offline

    quadros

    Регистрация:
    21 май 2007
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    проблему пытаюсь решить след образом:
    Процедура ПереносКатНомеров5()
    СпЗн = СоздатьОбъект("СписокЗначений");
    Док = СоздатьОбъект("Документ.Карточка");
    Мат = СоздатьОбъект("Справочник.Материалы");
    КатНом = СоздатьОбъект("Справочник.КаталогНомер");
    Док.ВыбратьДокументы(НачГода(РабочаяДата()),'31.12.07') ;

    Пока Док.ПолучитьДокумент()=1 Цикл
    Сообщить(""+Док);
    КатНом.ИспользоватьВладельца(Док.Карточка);
    Док.ВыбратьСтроки() ;
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если КатНом.НайтиПоНаименованию(Док.КаталожнНом,1)=1 Тогда
    НачОст=0+Док.Количество;
    КатНом.Кол.Установить(Док.ДатаДок,Док.Количество);
    Дат=НачГода(РабочаяДата());

    Пока Дат<'31.12.07' Цикл
    Прих=0;Розх=0;
    Док = СоздатьОбъект("Документ.ПриходТМЦ1");
    Док.ВыбратьДокументы(Дат,Дат) ;
    Док.ВыбратьСтроки() ;
    Пока Док.ПолучитьСтроку()=1 Цикл
    Прих=0+Прих+Док.Количество
    КонецЦикла;
    Дат=Дат+1;
    Док = СоздатьОбъект("Документ.РозходТМЦ");
    Док.ВыбратьДокументы(Дат,Дат) ;
    Док.ВыбратьСтроки() ;
    Пока Док.ПолучитьСтроку()=1 Цикл
    Розх=0+ Розх+Док.Количество
    КонецЦикла;
    ИтогТМЦ= НачОст+Прих-Розх;
    КатНом.Кол.Установить(Док.ДатаДок , ИтогТМЦ);
    КатНом.Записать();
    Дат=Дат+1;

    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
    но выдает ошибку КатНом.Кол.Установить(Док.ДатаДок , ИтогТМЦ);
    {D:\ХХХ\ХХХ\EXTFORMS\2.ERT(34)}: Недопустимая операция

    Подскажите как исправить...
  3. TopicStarter Overlay
    quadros
    Offline

    quadros

    Регистрация:
    21 май 2007
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Наверное все в отпуске

Поделиться этой страницей