8.х Разграничение скидки и наценки

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем umka), 27 май 2014.

  1. TopicStarter Overlay
    umka)
    Offline

    umka) Опытный в 1С

    Регистрация:
    17 янв 2012
    Сообщения:
    414
    Симпатии:
    0
    Баллы:
    26
    Ут 11.0.9.12 есть обработка по выгрузке данных( реализации ту) . как прописать условия для выгрузке только скидки (положит). В поле discount должен выгружать размер скидки в рублях (только скидок, наценки выгружать не нужно), значения должны быть положительными
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.429
    Симпатии:
    372
    Баллы:
    104
    и? где всё основное для того чтоб сформировать вам ответ?
    обработка ваша, что и откуда вы ей выгружаете и куда - знаете только вы.
  3. TopicStarter Overlay
    umka)
    Offline

    umka) Опытный в 1С

    Регистрация:
    17 янв 2012
    Сообщения:
    414
    Симпатии:
    0
    Баллы:
    26
    Код:
    // Запрос на список документов Реализация товаров
    ЗапросПоРеализациям = Новый Запрос;
    ЗапросПоРеализациям.Текст =
    "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Номенклатура,
    | РеализацияТоваровУслуг.Номенклатура.Код КАК НоменклатураКод,
    | СУММА(ВЫБОР
    | КОГДА РеализацияТоваровУслуг.Ссылка.ЦенаВключаетНДС
    | ТОГДА РеализацияТоваровУслуг.Сумма - РеализацияТоваровУслуг.СуммаНДС
    | ИНАЧЕ РеализацияТоваровУслуг.Сумма
    | КОНЕЦ) КАК Сумма,
    | РеализацияТоваровУслуг.Ссылка.Номер КАК НомерДокумента,
    | РеализацияТоваровУслуг.Ссылка.Дата КАК ДатаДокумента,
    | СУММА(РеализацияТоваровУслуг.Количество) КАК Количество,
    | РеализацияТоваровУслуг.Ссылка.Партнер,
    | РеализацияТоваровУслуг.Ссылка.Партнер.Код,
    | РеализацияТоваровУслуг.СтавкаНДС,
    | СУММА(РеализацияТоваровУслуг.СуммаРучнойСкидки + РеализацияТоваровУслуг.СуммаАвтоматическойСкидки) КАК СуммаСкидки,
    | РеализацияТоваровУслуг.Ссылка.ЦенаВключаетНДС,
    | РеализацияТоваровУслуг.Ссылка
    |ИЗ
    | Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |ГДЕ
    | РеализацияТоваровУслуг.Ссылка.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания
    | И РеализацияТоваровУслуг.Ссылка.Проведен = ИСТИНА
    | И РеализацияТоваровУслуг.Ссылка.Организация = &Организация
    | И РеализацияТоваровУслуг.Номенклатура В ИЕРАРХИИ(&СписокТоваров)
    | И РеализацияТоваровУслуг.Ссылка.Статус = &Статус
    |
    |СГРУППИРОВАТЬ ПО
    | РеализацияТоваровУслуг.Ссылка.Номер,
    | РеализацияТоваровУслуг.Ссылка.Дата,
    | РеализацияТоваровУслуг.Номенклатура,
    | РеализацияТоваровУслуг.Номенклатура.Код,
    | РеализацияТоваровУслуг.Ссылка.Партнер,
    | РеализацияТоваровУслуг.Ссылка.Партнер.Код,
    | РеализацияТоваровУслуг.СтавкаНДС,
    | РеализацияТоваровУслуг.Ссылка.ЦенаВключаетНДС,
    | РеализацияТоваровУслуг.Ссылка
    |
    |УПОРЯДОЧИТЬ ПО
    | ДатаДокумента,
    | НомерДокумента,
    | НоменклатураКод,
    | Сумма
    |АВТОУПОРЯДОЧИВАНИЕ";
    
    Если Объект.ВыгружатьПоВсемОрганизациям Тогда
    ЗапросПоРеализациям.Текст = СтрЗаменить(ЗапросПоРеализациям.Текст, "И РеализацияТоваровУслуг.Ссылка.Организация = &Организация", "");
    Иначе
    ЗапросПоРеализациям.УстановитьПараметр("Организация", Объект.Организация);
    КонецЕсли;
    
    ЗапросПоРеализациям.УстановитьПараметр("ДатаНачала", НачалоДня(Объект.ДатаНачала));
    ЗапросПоРеализациям.УстановитьПараметр("ДатаОкончания", КонецДня(Объект.ДатаОкончания));
    ЗапросПоРеализациям.УстановитьПараметр("Статус", Перечисления.СтатусыРеализацийТоваровУслуг.Отгружено);
    ЗапросПоРеализациям.УстановитьПараметр("СписокТоваров", СписокТоваров);
    ДокументыРеализации = ЗапросПоРеализациям.Выполнить().Выгрузить();
    
    
    
    // Реализации покупателям за период
    Для Каждого ТекЭлемент Из ДокументыРеализации Цикл
    СуммаСоСкидкой = ТекЭлемент.Сумма; // Здесь сумма с учетом скидки, и уже БЕЗ НДС
    
    Если ТекЭлемент.ЦенаВключаетНДС Тогда
    СуммаСкидки = ТекЭлемент.СуммаСкидки; // Тут сидит НДС, нужено его убрать
    СуммаСкидки = СуммаСкидки - Ценообразование.РассчитатьСуммуНДС(СуммаСкидки, ТекЭлемент.СтавкаНДС, Истина);
    СуммаБезСкидки = СуммаСоСкидкой + СуммаСкидки;
    Иначе
    СуммаСкидки = ТекЭлемент.СуммаСкидки;
    СуммаБезСкидки = СуммаСоСкидкой + СуммаСкидки;
    КонецЕсли;
    
    ФайлДанных.Добавить();
    ФайлДанных.WHCODE = "00000001";
    ФайлДанных.code = СокрЛП(ТекЭлемент.НоменклатураКод);
    ФайлДанных.oper_type = 0;
    ФайлДанных.doc_number = СокрЛП(ТекЭлемент.НомерДокумента);
    ФайлДанных.doc_parent = "";
    ФайлДанных.doc_date = Формат(ТекЭлемент.ДатаДокумента, "ДФ=ггггММдд");
    ФайлДанных.deliv_date = Формат(ТекЭлемент.ДатаДокумента, "ДФ=ггггММдд");
    ФайлДанных.clientcode = СокрЛП(ТекЭлемент.ПартнерКод);
    Если мВыгружатьТП Тогда
    ФайлДанных.TPCODE = "00000001";
    КонецЕсли;
    ФайлДанных.order_stat = 0;
    ФайлДанных.ru = 1;
    ФайлДанных.quantity = ТекЭлемент.Количество;
    ФайлДанных.amount = СуммаБезСкидки;
    ФайлДанных.discount = СуммаСкидки;
    ФайлДанных.bonus = 0;
    ФайлДанных.MANFID = Объект.MANFID;
    ФайлДанных.Записать();
    
    НоваяСтрока = ТаблицаДвиженияТоваров.Добавить();
    НоваяСтрока.Дата = НачалоДня(ТекЭлемент.ДатаДокумента);
    НоваяСтрока.НоменклатураКод = СокрЛП(ТекЭлемент.НоменклатураКод);
    НоваяСтрока.Расход = ТекЭлемент.Количество;
    
    // Проверяем, чтобы данный контрагент был в списке выгружаемых контрагентов:
    Если СписокКонтрагентов.Найти(СокрЛП(ТекЭлемент.ПартнерКод), "ПартнерКод") = Неопределено Тогда
    НСтр = СписокКонтрагентов.Добавить();
    НСтр.Партнер = ТекЭлемент.Ссылка.Партнер;
    НСтр.ПартнерКод = ТекЭлемент.Ссылка.Партнер.Код;
    НСтр.Контрагент = ТекЭлемент.Ссылка.Контрагент;
    НСтр.КонтрагентИНН = ТекЭлемент.Ссылка.Контрагент.Инн;
    НСтр.КонтрагентКПП = ТекЭлемент.Ссылка.Контрагент.КПП;
    НСтр.КонтрагентНаименованиеПолное = ТекЭлемент.Ссылка.Контрагент.НаименованиеПолное;
    КонецЕсли;
    
    КонецЦикла;
    Последнее редактирование модератором: 27 май 2014
  4. TopicStarter Overlay
    umka)
    Offline

    umka) Опытный в 1С

    Регистрация:
    17 янв 2012
    Сообщения:
    414
    Симпатии:
    0
    Баллы:
    26
    Какие нибудь идеи будут? посмотрите пожал
Похожие темы
  1. Ladys
    Ответов:
    3
    Просмотров:
    1.720
  2. AD1986
    Ответов:
    2
    Просмотров:
    690
  3. Golemchik
    Ответов:
    3
    Просмотров:
    597
Загрузка...

Поделиться этой страницей