7.7 Раздельная нумерация для документов по каждой фирме.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Не волшебник, 9 фев 2007.

  1. TopicStarter Overlay
    Не волшебник
    Offline

    Не волшебник

    Регистрация:
    5 фев 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Хочу организовать раздельную нумерацию для документа РасхНакл по каждой фирме.
    Для этого использую префикс, и по идее , если вызвать метод УстановитьНовыйНомер(Фирма.Префикс+"-") , то значение НомерДок должно меняться при выборе какой-либо из фирм. Однако не меняется.Пишу так:

    Процедура НовыйНомер()
    НомерДок.УстановитьНовыйНомер(Фирма.Префикс+"-");
    КонецПроцедуры

    Процедура ВводНового()
    Фирма=Константа.ОснФирма;
    Если Фирма.Выбран()=1 Тогда
    НомерДок.УстановитьНовыйНомер(Фирма.Префикс+"-");
    КонецЕсли;
    КонецПроцедуры

    Не пойму, где косяк.Кто подскажет?
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29

    Насколько мне известно, префикс ставиться для все базы и для собственного юридического лица. Мне кажется, чтобы создать префикс для Фирмы нужно копать глубже. Например, создать соответствующий реквизит для фирмы. Сам не пробовал, но начал бы оттуда.
  3. Синадонт
    Offline

    Синадонт

    Регистрация:
    9 фев 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Думаю, косяк в том, что при при изменении фирмы у Вас не вызывается процедура НовыйНомер()
    В процедуру, которая вызывается при изменении реквизита проставить эту процедуру. Или изменение префикса вставить в функцию ПриИзмененииФирмы(), по-моему такая есть. Если нет, то можно использовать предопределенную процедуру ПриНачалеВыбораЗначения(), по-моему так называется.

Поделиться этой страницей