8.х Расшифровка отчета

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем VIPOS, 30 окт 2012.

  1. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Доброго времени уважаемые форумчане!!!!!!!!!!

    Подскажите пожалуйста как сделать расшифровку отчета?!
    Т.е. существует определенная таблица (макет отчета), при выборе одной из ячеек появляется ее расшифровка (т.е. запуск еще одного отчета)

    Вложения:

  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.988
    Симпатии:
    399
    Баллы:
    104
    Отчет как написан? "Вручную", СКД и т.д.
  3. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.988
    Симпатии:
    399
    Баллы:
    104
    Если СКД, то вот маленький пример:
    Код:
    // Обработка расшифровки в отчете. (Обработка выполняется стандартная, просто решил выполнять ее кодом).
    // ................................................................................
    Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    перем ВыполненноеДействие;
    
    // Запретим стандартную обработку расшифровки
    СтандартнаяОбработка = Ложь;
    
    // Создадим и инициализируем обработчик расшифровки
    ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
    
    ДоступныеДействия = Новый Массив();
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Отфильтровать);
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Упорядочить);
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Сгруппировать);
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Оформить);
    
    // Осуществим выбор действия расшифровки пользователем
    Настройки = ОбработкаРасшифровки.Выполнить(Расшифровка, ВыполненноеДействие, ДоступныеДействия);
    
    Если Настройки <> Неопределено Тогда
    
    // Пользователь выбрал действие, для которого нужно менять настройки
    Если ВыполненноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.Упорядочить Тогда
    
    КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
    СформироватьОтчет();
    
    Иначе
    
    // При других действиях - создадим новый отчет, откроем форму, сформируем отчет в ней
    Отчет = Отчеты.уит_ДУД_ВведенныеДоговораЗаПериодTest.Создать();
    Форма = Отчет.ПолучитьФорму("ФормаОтчета");
    Форма.Открыть();
    Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
    Форма.СформироватьОтчет();
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры
    Если макет, то там уже можете сами что угодно написать. У табличного поля есть обработчик событий ОбработкаРасшифровки.Там все и прописывается. Расшифровка - это означает, что внутри ячейки содержится какое-то значение. У свойства ячейки есть параметр расшифровки. Указываете его, а в коде просто заполняете тем, чем нужно. Можно там прописать и формирование нового отчета.
  4. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Нет... отчет написан вручную......
    по созднию нового отчета вопросов не возникает, вопрос только в том как привязать процедуру создания к двойному щелчку по ячейке макета(((
  5. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    СПС=))
  6. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.988
    Симпатии:
    399
    Баллы:
    104
    Видать разобрался?!
  7. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Разобрался=)

Поделиться этой страницей