7.7 Расшифровка ячейки отчета

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Stranger12, 13 фев 2009.

  1. TopicStarter Overlay
    Stranger12
    Offline

    Stranger12

    Регистрация:
    13 фев 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Всем привет! Подскажите плиз
    В конструкторе отчетов создал отчет. Вот код:
    Код:
    Перем ПредставлениеРУ;
    Перем Обновить;
    Перем Расшифровка;
    //*******************************************
    Функция РасшифровкаОбновить(Обновить)
    Расшифровка.Установить("Обновить", Обновить);
    Возврат Расшифровка;
    КонецФункции
    //*******************************************
    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    
    
    
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьРазделительУчета(ВыбРазделительУчета);
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.СтатьиЗатрат,, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.Службы,, 1);
    Ит.ВыполнитьЗапрос(, ВыбКонПериода, ВыбСчет,,, 1,, "С");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСубконто(ВидыСубконто.Контрагенты);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл
    Таб.ВывестиСекцию("Субконто1");
    Ит.ВыбратьСубконто(ВидыСубконто.СтатьиЗатрат);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.СтатьиЗатрат) = 1 Цикл
    Таб.ВывестиСекцию("Субконто2");
    Ит.ВыбратьСубконто(ВидыСубконто.Службы);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Службы) = 1 Цикл
    Таб.ВывестиСекцию("Субконто3");
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    
    КонецПроцедуры
    //}}БУХГАЛТЕРСКИЙ ЗАПРОС  
    Процедура ПриОткрытии()
    
    //{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА(Сформировать)
    
    
    Вопрос! Что нужно вписать в код, чтобы по двойному клику мыши можно было расшифровывать ячейку
    полученной таблицы Отчетом "Карточка счета".
    Знатоки помогите пожалуйста
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Посмотри как работает в ОСВ
  3. TopicStarter Overlay
    Stranger12
    Offline

    Stranger12

    Регистрация:
    13 фев 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Мне общий принцип не понятен :(
    Что бы вызвать Карточку счета нужно описание субконто делать или там просто ссылка на нее прописывается
    ОСВ смотрел, но так и не понял:((
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Общий принцип таков, что запускается отчет карточки счета. но на момент его запуска переменная "Расшифровка" уже должна содержать исходные данные.
    Отчет открывается, заполняет все реквизиты и выводит таблицу.

Поделиться этой страницей