7.7 Распечатать таблицу значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 1 июн 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всем доброго времени суток. Вопрос должен быть легким для вас. Как распечатать таблицу значений? У меня в форме отчета есть реально существующая таблица значений ТЗ. Нужно распечатать все её ячейки: все строки и столбцы. Пробую это сделать, но на примере уже первой колонки ничего не получается. ДатаПлатеж является выражением в печатной таблице, но печатается не дата, а сама фраза "ДатаПлатеж" как-будто это текст. При этом число строк выводится правильное. Подскажите, пожалуйста, в чём же дело? Ниже код создания и заполнения таблицы (процедура Сформировать()), а затем печати таблицы (процедура ПечатьТаблицы(), её и надо исправить):
    Код:
    Процедура Сформировать()
    ТЗ.Очистить();
    ТЗ.ВставитьКолонку("Платежка",1,"Документ.ПлатежноеПоручение",,,"Платежка",,,);
    ТЗ.ВставитьКолонку("ДатаПлатежки",2,"Дата",,,"Дата платежки",13,,);
    ТЗ.ВставитьКолонку("ДатаВыписки",3,"Дата",,,"Дата выписки",12,,);
    ТЗ.ВставитьКолонку("НомерПлатежки",4,"Строка",8,,"Номер платежки",14,,);
    ТЗ.ВставитьКолонку("НадоПроводить",5,"Число",1,0,"Проводить?",10,,);
    ТЗ.ВставитьКолонку("Проведена",6,"Число",1,0,"Проведена?",10,,);
    ТЗ.ВставитьКолонку("Верно",7,"Число",1,0,"Верно?",5,,);
    ВытянутьПлатежки();
    ЗаполнитьДатыВыписки();
    ПроводитьЛи();
    ПравильноЛи();
    ТЗ.Сортировать("7+");
    СообщитьКосяки();
    КонецПроцедуры
     
    Процедура ПечатьТаблицы()
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Таблица");
        Таб.ВывестиСекцию("Шапка");
        ТЗ.ВыбратьСтроки();
        Пока ТЗ.ПолучитьСтроку() = 1 Цикл
            ДатаПлатеж=ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,2);
            Таб.ВывестиСекцию("Строка");
        КонецЦикла;
        Таб.Опции(0,0,0,0);
        Таб.ПараметрыСтраницы(1,,,0,0,,,,,,,);
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Печать отчета о проведении платежек в системе курсовых разниц","");
    КонецПроцедуры
  2. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Отбой этой теме! Всё нормально было и без метода ПолучитьЗначение()! Т.е. удалил строку модуля:
    Код:
    ДатаПлатеж=ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,2);
    
    Открыл в конфигураторе таблицу, что печатается. Выделил ячейку из секции "Строка", ещё раз выбрал тип "Выражение", заново написал ТЗ.ДатаПлатежки, и всё заработало. А заполнял таблицу сначала так: выделил всю строку, правой кнопкой щёлкнул и выбрал "свойства", затем установил тип - "выражение". После чего щелкал левой кнопкой мыши по ячейкам и сразу, не заходя в свойства писал что нужно. Видимо, 1с это не понравилось, так и не знаю, почему. Ну я не гордый - повторил и получил что хотел!

Поделиться этой страницей