8.х Раскраска строк

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Savant, 5 мар 2008.

  1. TopicStarter Overlay
    Savant
    Offline

    Savant Опытный в 1С

    Регистрация:
    19 ноя 2007
    Сообщения:
    252
    Симпатии:
    4
    Баллы:
    29
    Недавно начал изучать программирование на 8-ке. Есть такой вопрос:
    Имеется форма списка определенного документа. Необходимо закрасить в какой-либо цвет все строки, в которых некий реквизит принимает определенное значение.
    И ещё: Как изменить цвет фона не для всей строки, а только лишь для некоторых реквизитов?
    Заранее спасибо.
  2. Tverd
    Offline

    Tverd Опытный в 1С

    Регистрация:
    24 окт 2007
    Сообщения:
    56
    Симпатии:
    1
    Баллы:
    29
    Например в событие ПриВыводеСтрок этого Списка можешь вставить отлов реквизита и окраску.

  3. TopicStarter Overlay
    Savant
    Offline

    Savant Опытный в 1С

    Регистрация:
    19 ноя 2007
    Сообщения:
    252
    Симпатии:
    4
    Баллы:
    29
    Спасибо. Сейчас попробую.
  4. TopicStarter Overlay
    Savant
    Offline

    Savant Опытный в 1С

    Регистрация:
    19 ноя 2007
    Сообщения:
    252
    Симпатии:
    4
    Баллы:
    29
    В первом примере есть параметр "ОформлениеСтроки". Не могу его связать с моей таблицей (ЭлементыФормы.ДокументСписок). Как это вообще делается? Если можно - дайте маленький примерчик.
  5. Tverd
    Offline

    Tverd Опытный в 1С

    Регистрация:
    24 окт 2007
    Сообщения:
    56
    Симпатии:
    1
    Баллы:
    29
    Если относительно первого вопроса и события при выводе строк то как вариант так:

    Код:
    Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Красный = Новый Цвет(255, 0, 0);
    
    Если ДанныеСтроки.ПризнакРеквизита = ОпределенноеЗначение Тогда  //где ПризнакРевизита - ваш признак
    
    Для каждого Оформление из ОформлениеСтроки.Ячейки Цикл
    Оформление.ЦветФона = Красный;
    КонецЦикла;
    
    КонецЕсли;
    КонецПроцедуры
    
    

Поделиться этой страницей