[РЕШЕНО] Раскрасить фон строки табличной части документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем astra, 26 мар 2014.

  1. TopicStarter Overlay
    astra
    Offline

    astra Опытный в 1С

    Регистрация:
    6 фев 2013
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Всем привет!
    Как раскрасить фон строки табличной части документа, процедура должна срабатывать при открытии формы документа. По некоторым товарам необходимо подкрасить фон строк.

    Как это сделать?
    Можно пример кода?

    1С8.2, УТ 10
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    УФ?
    --- Объединение сообщений, 26 мар 2014 ---
    для обычного
    Код:
    Процедура тпГрафикПриПолученииДанных(Элемент, ОформленияСтрок)
       
       
        Для Каждого офСтроки Из ОформленияСтрок Цикл
            Если ЗначениеЗаполнено(офСтроки.ДанныеСтроки[0]) Тогда
                офСтроки.ЦветФона = WebЦвета.ДымчатоБелый;
            Иначе
                офСтроки.ЦветФона = WebЦвета.Белый;
            КонецЕсли;
        КонецЦикла;
       
    КонецПроцедуры
    
    --- Объединение сообщений, 26 мар 2014 ---
    Для УФ вроде условное овомление как то можно настроить - не пробовала
    astra нравится это.
  3. TopicStarter Overlay
    astra
    Offline

    astra Опытный в 1С

    Регистрация:
    6 фев 2013
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Спасибо!

Поделиться этой страницей