8.х Раскрашивание строк списков справочников

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Tayana_M, 25 май 2009.

  1. TopicStarter Overlay
    Tayana_M
    Offline

    Tayana_M Опытный в 1С

    Регистрация:
    14 янв 2009
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Уважаемые! Необходимо выделить цветом определенные номенклатурные позиции в справочнике номенклатуры в УТ 8.1. Подскажите, можно ли вообще это реализовать?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Пример есть в этой теме
  3. TopicStarter Overlay
    Tayana_M
    Offline

    Tayana_M Опытный в 1С

    Регистрация:
    14 янв 2009
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Но там же про ПКО?
  4. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    :)
    А по анологии сделать не судьба?
    Отдельным цветом закрасить всю строку наверное не выйдет. А вот некое поле пометить галочкой/картиночкой - вполне.
  5. tunec
    Offline

    tunec Опытный в 1С

    Регистрация:
    2 июн 2008
    Сообщения:
    469
    Симпатии:
    0
    Баллы:
    26
    на самом деле можно сделать свой список и в нем уже раскрасить строки :)

    А вообще я делал так:

    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Для Каждого строка из  ОформленияСтрок Цикл
    Если <Условие> Тогда
    строка.ЦветФона =Новый Цвет(230,255,230);    
    Иначе
    строка.ЦветФона =Новый Цвет(255,230,230);    
    КонецЕсли;
    КонецЦикла;
    
    КонецПроцедуры
    
    
    
    
    
    расскрашиваются все строки целиком :)

    П.С. что-то долго у мну ссылка которую привел BabySG открывалась, я уже запостил сообщение, а потом увидел, что по ссылке то же самое :)

Поделиться этой страницей