7.7 Расчет суммы значений неопределенного количества строк

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natalia_k, 19 июл 2010.

  1. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Всем привет!
    Подскажите, пожалуйста!
    Как вывести в ячейку таблицы отчета сумму значений нескольких строк, если их неограниченное количество.

    то есть, сумма в строчке А = значение1 + значение2 + ....+ N
  2. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    Например:

    Код:
    Итог("СуммаБезНДС");
    
    Также работает и для Объектов типа "ТаблицаЗначений":

    Код:
    ТабПартия.Итог("Вес");
    
  3. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Спасибо!
    А как быть, если у меня в таблице несколько секций, и вот между основной и секцией1 строки, которые могут добавляться. И нужно в размере средств напротив кода строки 120 посчитать сумму размера средств этих строк, в данном случае 121+122+123.

    А их может быть N-ое количество.

    Вложения:

  4. Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    приведи модуль, так будет легче разобраться
  5. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Вот пример!
    Помогите, пожалуйста!

    Вложения:

  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Использовать атрибут Текст и ВысотаТаблицы объекта Таблица
  7. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Извиняюсь, но не совсем поняла, как мне это использовать для подсчета суммы неопределенного количества строк.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1)Используя атрибут Текст можно получить значение конкретной ячейки
    2) Высота (количество строк) шапки вам известна.
    3) Начальноя строка второй секции тоже (или можно вычислить используя тот же метод Текст)
    4) В цикле суммируем значения ячеек....
  9. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    там в ячейке напротив 120 в таблице значений можно прописать формулу суммы этих строк, но так как видимы пока 3, то сумма считает всё верно, но если добавить еще строки, то предыдущие для отчета сохраняются, а новые просто встают на их место и для них опять отдельно сумма считается. А общую сумму не получается посчитать.

    Вложения:

  10. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерский угодник!

    Помоги, пожалуйста, правильно записать этот цикл расчета суммы
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Все значения введенные вручную хранятся в СпискеЗначений (общая переменная Список). Посмотрите процедуру ВыводитьСтроки там как раз идет получение сохраненных значений из списка (пригодится для суммирования). Количество строк хранится в переменной ЧислоСтрок
  12. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Можете ругаться на меня, но я новичок в этом деле, извините меня, но не понимаю я как записать эту функцию суммы для списка значений и как потом её вписать в таблицу значений.

    Приведите пример, пожалуйста!

    Мне очень нужно в этом разобраться.

    Бухгалтерский угодник, прости, что замучила. Научи, пожалуйста.
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Никто вас и не ругает... Дело обычное. Вы учитесь.
    Код:
    Процедура РасчетНужнойЯчейки()
    //все данные д.б. в СЗ.
    Для к = 1 По  ЧислоСтрок Цикл
    СохранитьДопСтроки(к,ЧислоСтрок,Список);
    КонецЦикла;
    Сумма=0;
    ДЛя к= 1 По Список.РазмерСписка() Цикл
    Сумма=Сумма+Список.ПолучитьЗначение(к);
    КонецЦикла
    Таблица.Область("Г2403").Значение=Сумма; //для примера присвоил результат 240й строке вашего отчета
    КонецПроцедуры
    
    

Поделиться этой страницей