7.7 Расчет по страховым взносам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ZEMA, 8 июл 2010.

  1. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    Всем привет, знаю что глупо, но все же спрашиваю...
    в ЗиК релиз 297 в отчете "Расчет по страховым взносам" нужно в строке 110-113 раздела 1-2 установить точность2, а по всем остальным точность чтоб осталась 0. Но не выходит((( Вот что я делаю
    Код:
    Процедура ОкруглитьЗначенияВТаблице(РезультирующаяТаблица, НомерНачальнойКолонки = 2) 
    
    //округлим суммы в таблице 
    Для СчСтрок = 1 По 4 Цикл    
    
    Для СчКолонок = НомерНачальнойКолонки По РезультирующаяТаблица.КоличествоКолонок() Цикл 
    Если (счстрок=4) и 	((СчКолонок=13) или (СчКолонок =14) ) тогда
    точность=2;
    КонецЕсли;
    
    РезультирующаяТаблица.УстановитьЗначение(СчСтрок,СчКолонок,Окр(РезультирующаяТаблица.ПолучитьЗначение(СчСтрок, СчКолонок),Точность));
    КонецЦикла;                                          			
    КонецЦикла;
    
    КонецПроцедуры
    
    
    кто может подскажет что не так
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы не учитываете что Точность - общая переменная модуля. Надо запоминать пердыдущее значение.... Сделайте так

    Код:
    Процедура ОкруглитьЗначенияВТаблице(РезультирующаяТаблица, НомерНачальнойКолонки = 2) 
    СтараяТочность=Точность;    
    //округлим суммы в таблице 
    Для СчСтрок = 1 По 4 Цикл    
    
    Для СчКолонок = НомерНачальнойКолонки По РезультирующаяТаблица.КоличествоКолонок() Цикл 
    Если (счстрок=4) и     ((СчКолонок=13) или (СчКолонок =14) ) тогда
    точность=2;
    Иначе 
    Точность=СтараяТочность;
    КонецЕсли;
    
    РезультирующаяТаблица.УстановитьЗначение(СчСтрок,СчКолонок,Окр(РезультирующаяТаблица.ПолучитьЗначение(СчСтрок, СчКолонок),Точность));
    КонецЦикла;                                                      
    КонецЦикла;
    Точность=СтараяТочность;
    КонецПроцедуры
    
    
    И поставьте 298й релиз. Иначе в ПФР не отчитаетесь. Подробнее здесь:
    http://www.1c-pro.ru/index.php?showtopic=23319
  3. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    А я сделал не совсем так как вы, просто при вызове переменных по строкам поставил окр(Значение,0), а в Процедура ОкруглитьЗначенияВТаблице точность так и оставил 2. Вас способ работает, почему-то я до него не додумался.Спасобо за помощь)))
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы еще и изменяли значение Точность в целом. А она используется не только в этой процедуре....

Поделиться этой страницей