7.7 Расчет нормы потребеления.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем roalang, 1 ноя 2013.

  1. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Раньше расчет потребления ОДН был по факту, теперь необходимо считать норму потребления.
    Подскажите пожалуйста как мне сравнить реквизит табличной части с элементом справочника Дома.
    Код:
     ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 цикл
    если (ПустоеЗначение(Дом)=1) или (ПустоеЗначение(норма)=1)	   тогда																
    Продолжить;
    конецесли;
    Кл.ПорядокКодов();
    Кл.ВыбратьЭлементыПоРеквизиту("Дом", Дом, 1,0) ;
    ПлДома=0;
    Пока Кл.ПолучитьЭлемент()=1 цикл  
    ПлДома=ПлДома+ Кл.ОбщПл.Получить(глДатаНачалаПериода); 
    КонецЦикла;  
    
    Дом_1= СоздатьОбъект("Справочник.Дома")  ;
    Дом_1.ВыбратьЭлементы();   
    Пока Дом_1.ПолучитьЭлемент()=1 цикл				  
    Если Дом_1.ЭтоГруппа()=1 Тогда
    Продолжить; //группы пропускаем, перейти в начало цикла
    КонецЕсли; 
    если Дом_1.ПринадлежитГруппе("Выбывшие")=1 тогда
    продолжить
    конецесли;  
    
    КонецЦикла;
  2. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Приведенный код ни о чем не говорит. Что именно нужно сравнить?
  3. TopicStarter Overlay
    roalang
    Offline

    roalang Опытный в 1С

    Регистрация:
    31 мар 2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Извините. в голове каша была. Вроде бы решила задачу. До этого месяца расчет ОДН брался по факту, т.е. энерго-сетевая компания, в начале каждого месяца предоставляли расшифровку потраченной жильцами электроэнергии. С 1 октября ввелся норматив потребления, и теперь надо сравнивать программно расчитанный факт и нормы потребления. Вроде бы разобралась сама.
  4. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Это было заметно)))))
Похожие темы
  1. maverick
    Ответов:
    1
    Просмотров:
    2.611
  2. Azgerd
    Ответов:
    4
    Просмотров:
    1.014
  3. Norvin
    Ответов:
    0
    Просмотров:
    486
  4. 0x0tnik87
    Ответов:
    2
    Просмотров:
    858
Загрузка...

Поделиться этой страницей