8.х Работа со строками ТаблицыЗначений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем KirillSemenov, 5 фев 2010.

  1. TopicStarter Overlay
    KirillSemenov
    Offline

    KirillSemenov

    Регистрация:
    2 дек 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Подскажите люди добрые где может быть ошибка?!
    Есть код
    Код:
    Чеки      = Новый ТаблицаЗначений();
    
    Чеки.Колонки.Добавить("Код");
    Чеки.Колонки.Добавить("Количество");
    Чеки.Колонки.Добавить("Цена");
    Чеки.Колонки.Добавить("Сумма");
    Чеки.Колонки.Добавить("Секция");
    Чеки.Колонки.Добавить("НомерЧека");
    Чеки.Колонки.Добавить("НомерТранзакции");	
    Чеки.Колонки.Добавить("ДК");
    
    
    Для К = 1 По МассивДляКодаТоваров.Количество()-1 Цикл
    ИскомаяСтрока = Чеки.Найти(МассивДляКодаТоваров[К],"Код");			
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если Не ИскомаяСтрока = "" Тогда 						Сообщить("Нашел "+МассивДляКодаТоваров[К]);					ИскомаяСтрока.Установить(МассивДляКодаТоваров[0],"ДК");	!!!!!!!!!!!!!!!!!!!	</span>
    КонецЕсли;
    КонецЦикла;                            //-- находит строки в ЧЕКИ по коду товара
    
    ИскомаяСтрока = "";
    
    
    В строке !!!!!!!! ошибка. Смысл в том, что в ИскомаяСтрока в Колонку ДК хочу поставить МассивДляКодаТоваров[0], а не выходит(((
    Помогите пожалуйса
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Думаю, что так. Не проверял.
    Код:
    Для К = 1 По МассивДляКодаТоваров.Количество()-1 Цикл
    ИскомаяСтрока = Чеки.Найти(МассивДляКодаТоваров[К],"Код");            
    Если Не ИскомаяСтрока = Неопределено Тогда                         
    Сообщить("Нашел "+МассивДляКодаТоваров[К]);         
    ИскомаяСтрока.ДК = МассивДляКодаТоваров[0];
    КонецЕсли;
    КонецЦикла;                            //-- находит строки в ЧЕКИ по коду товара
    
    
    
  3. TopicStarter Overlay
    KirillSemenov
    Offline

    KirillSemenov

    Регистрация:
    2 дек 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Именно так! я уже разобрался :)

    Подскажите как можно из строки символов пробелы удалить? Если известно что первый символ нужный а остальные пробелы. Где-то читал, не помню где) В дельфях были же операторы pos, del и т.д. для работы со строками
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    Вот тебе 2 функции

    СокрЛП (TrimAll)
    Синтаксис:
    СокрЛП(<Строка>)
    Параметры:
    <Строка> (обязательный)
    Тип: Строка. Исходная строка.
    Возвращаемое значение:
    Тип: Строка. Строка, полученная в результате отсечения пробелов .
    Описание:
    Отсекает незначащие символы, стоящие слева от первого значащего символа в строке, и пробелы, стоящие справа от последнего значащего символа в строке.
    Примечание:
    К незначащим символам относятся символы "пробел", "неразрывный пробел"(НПП), "табуляция" (горизонтальная Таб и вертикальная ВТаб), "возврат каретки" (ВК), "перевод строки" (ПС), "перевод формы (страницы)" (ПФ).
    Пример:
    НаименованиеДляПечати = СокрЛП(Товар.Наименование);




    СтрЗаменить (StrReplace)
    Синтаксис:
    СтрЗаменить(<Строка>, <Подстрока поиска>, <Подстрока замены>)
    Параметры:
    <Строка> (обязательный)
    Тип: Строка. Исходная строка.
    <Подстрока поиска> (обязательный)
    Тип: Строка. Искомая подстрока.
    <Подстрока замены> (обязательный)
    Тип: Строка. Подстрока, на которую будет заменена подстрока поиска.
    Возвращаемое значение:
    Тип: Строка. Строка, полученная в результате замены.
    Описание:
    Находит в исходной строке все вхождения подстроки поиска и заменяет ее на подстроку замены.
    Пример:
    Результат = СтрЗаменить(Номенклатура.Наименование, "_", " ");
  5. TopicStarter Overlay
    KirillSemenov
    Offline

    KirillSemenov

    Регистрация:
    2 дек 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    О точно в справке и читал! Спасибо!

Поделиться этой страницей