8.х Работа со справочником

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Larin, 25 окт 2008.

  1. TopicStarter Overlay
    Larin
    Offline

    Larin

    Регистрация:
    11 окт 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.

    Я новичек, нахожусь в процессе обучения.
    Есть 2 справочника: номенклатура и единицы измерений.
    В номенклатуре есть булево "услуга", при нажатие на которую должен выбираться предопределенный элемент справочника ЕденицыИзмерения

    Мой нерабочий вариант.
    Код:
     Процедура УслугаПриИзменении(Элемент)
    ЕдИзм=Справочники.ЕденицыИзмерения.Штуки;
    НомЕдИзм=ЭлементыФормы.ОснЕденицаИзмерения;
    Если Истина Тогда
    НомЕдИзм=ЕдИзм;
    Иначе
    НомЕдИзм=0;
    КонецЕсли
    КонецПроцедуры
    
    
    
    КонецЕсли Ложь он вообще не воспринимает.
    Откуда я начал неправильно мыслить? И вообще правильно ли хоть где?

    Оффтоп
    У меня в конфигураторе когда я хочу дописать что либо перед выражением, да и любым словом, вместо того чтобы добавить символы, заменяет существующие... Как это отключить, Гуглить пытался, но я даже не представляю какой поисковый запрос сформировать.
  2. Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    клавишу insert отключи
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Учите матчасть!
    Если Истина Тогда - что это по вашему?
  4. TopicStarter Overlay
    Larin
    Offline

    Larin

    Регистрация:
    11 окт 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Да спасибо дошло!

    Я совсем еще ламмер, но придет время... Всем спасибо!

Поделиться этой страницей