8.х Работа с xml

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем grish, 12 сен 2006.

  1. TopicStarter Overlay
    grish
    Offline

    grish

    Регистрация:
    12 сен 2006
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Как средствами 1С8 получить список дочерних узлов xml?
  2. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    Чтение = Новый ЧтениеXML;
    Чтение.ОткрытьФайл(ПутьКФайлу);

    Пока Чтение.Прочитать() Цикл

    // Прочитать "структурные части" элементов.
    // Проверить, какая часть элемента - текущая.
    Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
    ИмяУзла = Чтение.Имя; Сообщить("--" + ИмяУзла);

    // Атрибуты элементов можно читать только если текущая часть -
    // начало элемента
    Пока Чтение.ПрочитатьАтрибут() Цикл

    // Прочитать данные узла атрибута.
    ТипУзла = Чтение.ТипУзла;
    Имя = Чтение.Имя;
    Значение = Чтение.Значение;

    // Обработать полученные значения.

    КонецЦикла;

    ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.Текст Тогда

    // В примере просто выводим текст в окно сообщений.
    Сообщить("Текст:" + Чтение.Значение);

    ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда

    // В примере просто выводим признак конца элемента
    // в окно сообщений Сообщить("--Конец:" + Чтение.Имя);

    КонецЕсли;

    КонецЦикла;

Поделиться этой страницей