8.х Работа с Временным Хранилищем 1С УФ

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Ludmillka, 19 ноя 2013.

  1. TopicStarter Overlay
    Ludmillka
    Offline

    Ludmillka Опытный в 1С

    Регистрация:
    13 сен 2013
    Сообщения:
    159
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, помогите разобраться с ПоместитьВоВременноеХранилище и ПолучитьИзВременногоХранилища. Задача такая: Есть Объект1 с Формой1 из нее открывается Обработка2 в которой надо установить Реквизит2= Объект1.Ссылка.

    Я делаю так:
    В модуле формы1
    Код:
    &НаКлиенте
    Процедура ДобавитьПриложение(Команда)
    Родитель=Объект.Ссылка;
    РодительХранилище=ПоместитьВоВременноеХранилище(Родитель);
    Форма=ПолучитьФорму("Обработка.СканированиеПриложений.Форма.ФормаУправлемая");
    Форма.Открыть();
    
    
    КонецПроцедуры
    
    
    
    а потом в модуле Обработки2
    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Объект.Родитель=ПолучитьИзВременногоХранилища(РодительХранилище);
    КонецПроцедуры
    
    И конечно же 1С ругается на РодительХранилище которая не определена.
    Подскажите, как надо делать, создавать реквизит РодительХранилище у формы Обработки2, но как туда передать данные? В общем я запуталась...
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    у управляемой формы есть свойство Параметры, тип ДанныеФормыСтруктура. Поробуйте туда перед открытием вставить
  3. Aston
    Offline

    Aston Опытный в 1С

    Регистрация:
    6 июн 2012
    Сообщения:
    467
    Симпатии:
    3
    Баллы:
    29
    Мне кажется вы изобритаете велосипед. Попробуйте после тога как форма создана на сервере, проверить у обработки ЭтаФорма.Родитель - не помню так вроде.
  4. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Соглашусь с nickpugachev. Временное хранилище чаще используют для передачи, например, таблицы и других "больших" данных.
    Ссылку можно просто передать через параметры формы.

    В модуле формы1
    Код:
    &НаКлиенте
    Процедура ДобавитьПриложение(Команда)
    ПараметрыОткрытия = Новый Структура("СсылкаНаРодителя", Объект.Ссылка);
    ОткрытьФорму("Обработка.СканированиеПриложений.Форма.ФормаУправлемая", ПараметрыОткрытия);
    КонецПроцедуры
    а потом в модуле Обработки2
    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Объект.Родитель = Параметры.СсылкаНаРодителя;
    КонецПроцедуры
  5. TopicStarter Overlay
    Ludmillka
    Offline

    Ludmillka Опытный в 1С

    Регистрация:
    13 сен 2013
    Сообщения:
    159
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое!

Поделиться этой страницей