7.7 Работа с текстом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Time dont wait, 20 окт 2009.

  1. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Вот исходный код:
    Код:
    Процедура Выполнить()
    
    Файл = СоздатьОбъект("Текст");
    Спр = СоздатьОбъект("Справочник.Сотрудники"); 
    Спр.ИспользоватьРодителя("Работающие");
    Файл.Открыть("D:\SpPRc.txt");
    
    НомСтр = 1;
    Пока НомСтр <= Файл.КоличествоСтрок() Цикл
    
    Код = СокрЛП(Файл.ПолучитьСтроку(НомСтр));
    Наименование = СокрЛП(Файл.ПолучитьСтроку(НомСтр+1));
    Если Спр.НайтиПоКоду(Код)= 0 Тогда
    Спр.Новый();
    Спр.Код=Код;
    Спр.Наименование = Наименование;
    Спр.Записать();
    КонецЕсли;
    
    НомСтр = НомСтр + 2;
    КонецЦикла;
    
    КонецПроцедуры
    
    Проблема в том, что всех сотрудников кидает прямо в справочник, а не в грРаботающие, помогите - в чем тут ошибка??
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Подозреваю, что вместо
    Код:
    Спр.ИспользоватьРодителя("Работающие"); 
    
    Должно быть нечто вроде

    Код:
    Спр.ИспользоватьРодителя(Справочники.Сотрудники.НайтиПоНаименованию("Работающие")); 
    
    Ну или как то так, передавая не строку, а ссылку на группу справочников...
  3. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Код:
    Спр.ИспользоватьРодителя(Справочники.Сотрудники.НайтиПоНаименованию("Работающие")); 
    
    
    не получается, и так тоже:
    Код:
    Спр.ИспользоватьРодителя(Справочники.Сотрудники.НайтиПоНаименованию("Работающие")); 
    Спр.Родитель="Работающие";
    
    
  4. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Вам же уже сказали, что нужно использовать ссылку на элемент справочника, а не строку с названием. Только пример кода из восьмерки привели:)
    Нужно так, примерно:
    Код:
    Родитель = СоздатьОбъект("Справочник.Сотрудники");
    Родитель.НайтиПоНаименованию("Работающие");
    Спр = СоздатьОбъект("Справочник.Сотрудники");
    Спр.ИспользоватьРодителя(Родитель);
    
  5. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Каюсь, я на 77 уж два года не прогал...
  6. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Либо просто
    Код:
    Спр.Родитель = Родитель;
    
  7. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Всем спасибо, извините, но я 1с 3 недели назад первый раз увидел
    Я еще чайник, но учусь..))

Поделиться этой страницей