8.х Работа с POP3 сервером

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем v0233, 15 янв 2011.

  1. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Нашел вот такую процедуру по приему сообщений с


    Код:
    Процедура ПолучениеПочты()
    
    //создадим новый объект
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    //Пропишем параметры соединения
    //ip адрес или имя POP3 сервера
    Профиль.АдресСервераPOP3 = УчетнаяЗапись.POP3Сервер;
    
    
    //Порт SMTP сервера
    Профиль.ПортPOP3 = ПортСервераPOP3Рассылки;
    
    //Имя пользователя почтового ящика
    Профиль.Пользователь = Пользователь;
    
    //Пароль доступа к почтовому ящику
    Профиль.Пароль = Пароль;
    
    // Создаем объект для работы с почтой
    ИнтернетПочта  = Новый ИнтернетПочта; 
    
    //Выполняем подключение, согласно указанный параметров
    Попытка
    ИнтернетПочта.Подключиться(Профиль);
    Исключение
    //При подключении возникла ошибка, сообщим
    Сообщить("Ошибка при подключении к серверу" + ОписаниеОшибки());
    Возврат;
    КонецПопытки;
    
    //Выбираем все  письма в массив
    МассивСообщений = Новый Массив;
    МассивСообщений = ИнтернетПочта.Выбрать(Истина);             
    
    //Разбираем каждое письмо, и выполняем необходимые действия
    Для Каждого Письмо Из МассивСообщений Цикл
    
    //Получение вложений в писье
    Вложения = Письмо.Вложения;
    Тема      =  Письмо.Тема;
    Тексты      =  Письмо.Тексты;
    
    //..... и т.д.
    
    КонецЦикла;                   
    КонецЕсли;
    
    //После получения закрываем соединение
    ИнтернетПочта.Отключиться();
    
    КонецПроцедуры
    
    У меня два косяка, все письма после этого кода удаляются с сервера.
    а я не хочу чтобы они удалялись,

    Письмо.Тексты
    выдает
    "ИнтернетТекстыПочтовогоСообщения"
    Вместо текста в сообщении.

    Письмо.Тема
    отображается правильно,
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
  3. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    :angry:

    Спасибо,
    Но я мало что понял. думаю на примере будет более понятнее.
  4. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Код:
    МассивСообщений = ИнтернетПочта.Выбрать(Ложь);
    
  5. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    странно но я не могу прочесть текст в письме вот что выходит

    Код:
    Для Каждого Письмо Из МассивСообщений Цикл
    
    //Получение вложений в писье
    
    Тема      =  Письмо.Тема;
    Тексты      =  Письмо.Тексты;
    
    
    Сообщить (" Тема письма "+Тема+" текст письма " + Тексты);
    //..... и т.д.
    
    КонецЦикла;
    
    
    Тема письма Re: Fwd: текст письма ИнтернетТекстыПочтовогоСообщения
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Потому что "Письмо.Тексты" это не строка. Воспользуйтесь синтакс-помощником и посмотрите какой тип имеет это поле (подсказка и так у вас видна при выводе).

Поделиться этой страницей