7.7 Работа с КорСубконто

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем freddy_kind, 31 окт 2007.

  1. TopicStarter Overlay
    freddy_kind
    Offline

    freddy_kind

    Регистрация:
    12 сен 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Товарищи, написал отчет по проводкам 10-го счета, потом появилась необходимость добавить Контрагента из КорСчета(Контрагент есть только в проводке с 60-м счетом), добавил просто ИспользоватьКорСубконто и соответственно цикл по КорСубконто. Контрагент появился, но данные выводит не те:( Почему? Может надо было по другому как то этого Контрагента добавлять?
  2. TopicStarter Overlay
    freddy_kind
    Offline

    freddy_kind

    Регистрация:
    12 сен 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");  
    Ит.ИспользоватьСубконто(ВидыСубконто.Подразделения,ПодрСклад,2);  
    Ит.ИспользоватьСубконто(ВидыСубконто.Материалы);
    Ит.ВыполнитьЗапрос(ДатаН,ДатаК,"10.2,10.3,10.4,10.5,10.6,10.7,10.8,10.9,10.10,10.11,10.12",,,3); 
    Ит.ВыбратьСубконто(2);
    Пока Ит.ПолучитьСубконто(2)=1 Цикл  
    Если (Ит.СНД()>0) и (Ит.ДО()=0) и (Ит.КО()=0) Тогда
    Если (ФлПовт=0) Тогда
    Уточнен="1. Подразделения не брали, на склад не заказывали";
    Таб.ВывестиСекцию("Шапка");
    ФлПовт=1;
    КонецЕсли;    
    Таб.ВывестиСекцию("Строка");    
    КонецЕсли;    
    КонецЦикла; 
    ФлПовт=0;
    
    
    Добавил ИспользоватьКорСубконто, может не так что??

    Пожалуйста, используйте тэг
    Код:
    [/color]
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29


    А где выбор по корсубконто?
  4. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    1-ое ИТ.ИспользоватьКорСубконто(<ВидСубконто>,<Субконто>,<ТипФильтра>,<ПоГруппам>);
    должно быть перед запросом
    2-ое во втором цикле :
    ИТ.ВыбратьКорСубконто(<Индекс>,<ФлагВсе>,<ФлагДК>,<Номер>,<Сортировка>,<ОбратныйПорядок>);
    пока ИТ.ПолучитьКорСубконто(<Индекс>,<Номер>,<Значение>)=1 цикл
    ...
    КонецЦикла;
    :unsure:

Поделиться этой страницей