8.х Работа с формой. Проблема такая.....

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем AUBalan, 25 мар 2014.

  1. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Добрый день, уважаемые форумчане!
    Вопрос в следующем:
    Рисунок1.png
    Вот такой кусок формы есть.
    Как осуществить это действие?
    Чтобы запись из поля "Ваш комментарий" передавалась в большое поле "комментарии". при нажатии на кнопку "Добавить".
    И в последствии, при добавлении других записей новые также добавлялись в это большое поле друг за другом...

    Заранее спасибо!!!
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Код:
    &НаКлиенте
    Процедура ГотовоНажатие()
    Комментарии = ВашКомментарий;
    ОбновитьОтображениеДанных()
    КонецПроцедуры
    Комментарии и ВашКомментарий - реквизиты формы.
  3. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    БольшоеПоле=БольшоеПоле+"
    "+Строка(МалоеПоле)
    Это имелось в виду?
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Нет, это имелось ввиду
    --- Объединение сообщений, 25 мар 2014 ---
    Так, милый человек, бегом в книжный магазин, ну или на ОЗОН, и заказывайте версию для обучения программирования.
  5. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    ?
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Если даже такие вопросы вас мучают, то я не знаю чем вам еще помочь.
  7. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Но как сделать, чтобы в большое поле "комментарии", следующие комментарии ДОЗАПИСЫВАЛИСЬ, тут та инфа просто обновляется....
    Заранее спасибо!
  8. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    Автор требовалось значениями из одного поля "Ваш комментарий" дополнять значение поля "Комментарий".
    На кнопку требовалось прикрепить действие по "дополнению" реквизита, т.е. "Комментарий"="Комментарий"+"Ваш комментарий". Так же требовалось каждый новый комментарий добавлять с новой строки. т.е.
    Код:
    Комментарий=Комментарий+"
    "+Ваш комментарий.
    
    Что не так?
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Вот так:
    Код:
    &НаКлиенте
    Процедура ГотовоНажатие()
    Комментарии = Комментария + ВашКомментарий;
    ОбновитьОтображениеДанных()
    КонецПроцедуры
    --- Объединение сообщений, 25 мар 2014 ---
    Алекс_фесс, я не вам писал пост № 4 :)
  10. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    Код:
    &НаКлиенте
    Процедура ГотовоНажатие()
    Комментарии = Комментария + "
    "ВашКомментарий;
    ОбновитьОтображениеДанных()
    КонецПроцедуры
    Если уж на то пошло;)
  11. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Уважаемый ТС, я в коде насильно допустил ошибку - разберетесь - молодец :), не разберетесь - не молодец:D
  12. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    alexburn, Прошу прощения глаз замылился :)
  13. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Спасибо учитель. ))))) Ваше конфу лучше чем мое))))
  14. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Это к чему:) ?
  15. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    alexburn, спасибо! Извини за такие вопросы, я совсем новичок. Пытаюсь учиться, создаю собственную конфигурацию... Не мог бы подсказать литературу для изучения языка? Заранее спасибо!
  16. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Читай пост № 4, как раз для тебя писал :)
  17. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Просто шутка))))
  18. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    ааа, вон че:D, блин, сбил меня с толку.

Поделиться этой страницей