8.х Работа с формой элемента справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Storm03, 27 фев 2007.

  1. TopicStarter Overlay
    Storm03
    Offline

    Storm03

    Регистрация:
    27 фев 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Надо в справочнике Контрагенты сделать так, чтобы пользователь не мог начать ввод краткого наименования с "ООО", "ЗАО" и т.п.
    С этой целью через палитру свойств вставил процедуру:

    Процедура КраткоеНаименованиеПриИзменении(Элемент)
    Если Лев(ЭлементыФормы.КраткоеНаименование ,3)= "ООО" Тогда Предупреждение("Краткое наименование"+Символы.ПС+"не может начинаться"+Символы.ПС+"с ООО!",20,"ВНИМАНИЕ!"); ЭлементыФормы.КраткоеНаименование = ""; КонецЕсли;
    // Здесь такие же Если для ЗАО, ИП, МУП
    КонецПроцедуры

    Но почему-то не работает...
    Не подскажете, в чем ошибка?
    Заранее спасибо.
  2. GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    Правильнее будет сделать при записи проверку это раз ,
    Если нрег(Лев(СокрЛП(ЭлементыФормы.КраткоеНаименование),3))="ооо" тогда
    Сообщить("Лузер вводи правильно ");
    Возврат
    // примерно так
    КонецЕсли;
  3. TopicStarter Overlay
    Storm03
    Offline

    Storm03

    Регистрация:
    27 фев 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Попробовал.
    Получилось:
    Если Нрег(Лев(СокрЛ(ЭлементыФормы.КраткоеНаименование.Значение) ,3))= "ооо" Тогда ...
    Спасибо за подсказку Нрег()! Сам бы не догадался вставить! :unsure:

Поделиться этой страницей