7.7 Работа с файлом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Сергей123, 23 окт 2013.

  1. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Доброго всем дня. есть небольшая проблема. нужно создать обработку, которая автоматически проверяет каждые минут 5 наличие файла в папке. причем у файлов могут быть разные имена. как это осуществить? и возможно ли это?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Все возможно. Набор имен известен или нет? Нужно просто проверять наличие файла в паке или как?
    Уточните задачу конкретнее
  3. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    набор имен файла это структура: номер файла (например:0001, 0002, 0003 и т.д.) + номер телефона (всегда разные). Просто проверить..... если есть он, то выдать сообщение - "есть файл"
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    	  
    Если ПустоеЗначение(ФС.НайтиПервыйФайл(НужныйВамКаталог+"\*.*"))=0 Тогда
    Сообщить("Есть файл в каталоге "+НужныйВамКаталог);
    КонецЕсли;
    
  5. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Все получилось, спасибо....только чуть исправил:
    (ФС.НайтиПервыйФайл(НужныйВамКаталог+"\*.*"))
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Прошу прощения... Все оказалось не так просто. Вот рабочий код
    Код:
    Функция ВернутьПервыйФайл(НужныйВамКаталог)
    Имя=ФС.НайтиПервыйФайл(НужныйВамКаталог+"\*.*");
    Пока ПустоеЗначение(Имя)=0 Цикл	  
    Имя=ФС.НайтиСледующийФайл();
    Если Лев(Имя,1)<>"." Тогда
    Возврат Имя;
    КонецЕсли;
    КонецЦикла;
    Возврат "";
    КонецФункции
    //*******************************************
    Процедура Сформировать()		
    
    Если ПустоеЗначение(ВернутьПервыйФайл(НужныйВамКаталог))=0 Тогда
    Сообщить("Есть файл в каталоге "+НужныйВамКаталог);
    Иначе
    Сообщить("Нет файла");
    КонецЕсли;
    КонецПроцедуры
    
    это уже было исправлено сразу. Просто писал здесь, а не в конфигураторе.
  7. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое. все получилось.....работает :)
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей