8.х Работа с файлами

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем MaxxSoft, 19 апр 2007.

  1. TopicStarter Overlay
    MaxxSoft
    Offline

    MaxxSoft

    Регистрация:
    23 мар 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день, знатоки!
    Пишу свою первую обработку, поэтому будьте снисходительны...
    Стоит простая задача - написать обработку для импорта / экспорта документа из / в файл.

    Вопросы следующие:
    Как создать файл на диске, открыть его для чтения / записи, и прочитать / записать из / в него данные?
  2. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Файл какого приложения?
    Какой документ?
  3. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Простейший пример - работа с обычным текстовым файлом

    Выгрузка

    //########################################
    Текст = Новый ТекстовыйДокумент;
    Выборка = Справочники.Номенклатура.Выбрать();

    Пока Выборка.Следующий() Цикл
    Стр = СтрЗаменить(Выборка.Наименование, Символ(34), "%квч%");
    Код = Строка(Выборка.Код)+Символ(34);
    Текст.ДобавитьСтроку(Код + Стр);
    КонецЦикла;

    Текст.Записать("c:\text.txt");

    //########################################
  4. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Загрузка

    //########################################
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать("c:\text.txt");

    Для НомерСтроки=1 По Текст.КоличествоСтрок() Цикл
    Стр = Текст.ПолучитьСтроку(НомерСтроки);
    Позиция = Найти(Стр, Символ(34));
    Код = Сред(Стр, 1, Позиция-1);
    прНаименование = Сред(Стр, Позиция+1);
    Наименование = СтрЗаменить(прНаименование, "%квч%", Символ(34));

    Сообщить(Код + "-" + Наименование);

    КонецЦикла;

    //########################################
  5. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Работа с текстом. В предыдущем примере документ загружался полностью.
    Ниже будет рассматриваться модель последовательного (построчного) доступа.

    Запись

    //#########################

    Путь = "c:\text.txt";
    Текст = Новый ЗаписьТекста(Путь, КодировкаТекста.UTF8);
    Выборка = Справочники.Номенклатура.Выбрать();

    Пока Выборка.Следующий() Цикл
    Текст.ЗаписатьСтроку(Выборка.Наименование);
    КонецЦикла;

    //#########################




    Чтение

    //#########################

    Путь = "c:\text.txt";
    Текст = Новый ЧтениеТекста(Путь, КодировкаТекста.UTF8);
    Стр = Текст.ПрочитатьСтроку();

    Пока Стр <> Неопределено Цикл
    Стр = Текст.ПрочитатьСтроку();
    Сообщить(Стр);
    КонецЦикла;

    //#########################
  6. TopicStarter Overlay
    MaxxSoft
    Offline

    MaxxSoft

    Регистрация:
    23 мар 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо, вчера уже нашел объект ТекстовыйДокумент, вроде разобрался.
  7. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    С документами приложений офиса чуть посложнее. Надо немного VBA знать.
    Рад тому, что помог.
  8. onfly
    Offline

    onfly

    Регистрация:
    18 июн 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Требую продолжение банкета :)
    Можно примеры для ворда и/или ссылки какие-нибудь интересные?
    Спасибо.

Поделиться этой страницей