8.х Работа с файлами

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Muggsy, 24 сен 2009.

  1. TopicStarter Overlay
    Muggsy
    Offline

    Muggsy одно ЭС

    Регистрация:
    10 сен 2008
    Сообщения:
    243
    Симпатии:
    0
    Баллы:
    26
    пишу так:
    Код:
    ИмяФайла = "C:\Export.txt"; 
    ВыбФайл = Новый Файл(ИмяФайла);
    
    Если ВыбФайл.СуществуетФайл("C:\Export.txt") = 1 Тогда   
    ТекстРасчета = "";
    ТекстПараметры.Прочитать("C:\Export.txt");
    Для к=1 По ТекстПараметры.КоличествоСтрок() Цикл   
    Если к=1 Тогда
    ТекстРасчета= Текст.ПолучитьСтроку(к); 
    Иначе   
    ТекстРасчета= ТекстРасчета+ТекстПараметры.РазделительСтрок+Текст.ПолучитьСтроку(к);
    КонецЕсли;
    КонецЦикла;  
    
    
    далее надо скопировать этот файл в некоторую директорию и удалить, среди методов ВыбФайл я таких не обнаружила, как это сделать?
    и еще вопрос, а то в восьмерке нет функции каталогИБ(), как можно получить путь к директории базы данных?
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!

    Вот Вам пример

    Код:
    ИмяКаталога = РаботаСФайлами.ПолучитьИмяКаталога();
    Если РаботаСФайлами.ПроверитьСуществованиеКаталога(ИмяКаталога) = Ложь Тогда
    Сообщить("Ошибка открытия рабочего каталога");
    Отмена = Истина;
    Возврат Неопределено;
    КонецЕсли;
    ИмяНовогоФайла = "Файл выгрузки заказов.xml"; 
    ИмяНовогоФайлаПолное = РаботаСФайлами.ПолучитьИмяФайла(ИмяКаталога, ИмяНовогоФайла);
    // Создаем новый файл
    ТекстовыйДокумент = Новый ТекстовыйДокумент;
    ТекстовыйДокумент.Записать(ИмяНовогоФайлаПолное);
    
    НовыйФайл = Новый ДвоичныеДанные(ИмяНовогоФайлаПолное);
    НовыйФайл.Записать(ИмяНовогоФайлаПолное);
    
    
    Для удаления файла

    Код:
    УдалитьФайлы (DeleteFiles)
    Глобальный контекст
    УдалитьФайлы (DeleteFiles)
    Синтаксис:
    УдалитьФайлы(<Путь>, <Маска>) 
    Параметры:
    <Путь> (обязательный)
    Тип: Строка. Путь к удаляемым файлам. 
    <Маска> (необязательный)
    Тип: Строка. Маска для выбора удаляемых файлов. В строке маски допускается использование символа "*" (звездочка), обозначающего любое число произвольных символов, и "?" (знак вопроса), обозначающего один произвольный символ.
    Если <Маска> не указана, то удаляются все файлы и каталог <Путь>. 
    Описание:
    Удаляет указанные файлы. 
    Примечание:
    Для удаления одного файла, можно передать его полное имя через первый параметр, либо передать путь к нему через первый параметр, а его короткое имя - через второй.
    Удаление файлов производится, если в указанных файлах не установлено свойство "Только чтение". В противном случае возникает сообщение об ошибке.
    Допускается использование схем http, https <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и ftp для адресации файлов. При использовании этих схем в адресах необходимо указывать прямые слеши '/', а не обратные '\'. </span>
    Пример:
    // Удаление каталога и всех вложенных в него каталогов и файлов
    Попытка
    УдалитьФайлы("C:\temp\Works"); 
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
  3. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Код:
    ВыбФайл.СуществуетФайл("C:\Export.txt")
    
    Это, вроде, из семерки :) В 8 "Существует" используется.

    Для копирования , удаления (а может просто перемещения?) используются соответственно:
    Код:
    КопироватьФайл(<Имя файла источника>, <Имя файла приемника>);
    УдалитьФайлы(<Путь>, <Маска>);
    ПереместитьФайл(<Имя файла источника>, <Имя файла приемника>);
    
    
    Для определения местоположения базы можно использовать
    Код:
    СтрокаСоединенияИнформационнойБазы();
    

Поделиться этой страницей