8.х Работа с элементом справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем expreSsive, 25 ноя 2009.

  1. TopicStarter Overlay
    expreSsive
    Offline

    expreSsive

    Регистрация:
    9 ноя 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте

    проблема такая.я ищу по коду элемент справочника, нужно заполнить таблицу значениями из этого справочника - наименование и количество, при этом их может быть несколько.как доработать существующий код?

    Код:
    ТабличнаяЧасть = ПереченьНоменклатуры;
    Элемент = Справочники.Наборы;
    РезультатПоиска = Элемент.НайтиПоКоду(123);
    
    Для Каждого ТекСтрока Из РезультатПоиска Цикл
    СтрокаТабличнойЧасти = ТабличнаяЧасть.Добавить();
    СтрокаТабличнойЧасти.Наименование     =;
    СтрокаТабличнойЧасти.Количество     =;
    КонецЦикла;
    
    
    Спасибо за внимание
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    У вас может быть несколько значений справочника с одинаковым кодом?? Это Зачем такое??

    Спр = Справочники.Наборы.НайтиПоКоду("123"); // в какой структуре храниться код (строка или число)
    Строка = ТЧ.Добавить();
    Строка.Наименование = Спр.Наименование;
    Строка.Количество = Спр.Количество;
  3. alborovoy
    Offline

    alborovoy

    Регистрация:
    23 окт 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Код:
    ТабличнаяЧасть = ПереченьНоменклатуры;
    Элемент = Справочники.Наборы;
    РезультатПоиска = Элемент.НайтиПоКоду(123);
    
    Для Каждого ТекСтрока Из РезультатПоиска Цикл
    СтрокаТабличнойЧасти = ТабличнаяЧасть.Добавить();
    СтрокаТабличнойЧасти.Наименование     = ТекСтрока.Наименование;
    СтрокаТабличнойЧасти.Количество     = ТекСтрока.Количество;
    КонецЦикла;
    
    
    Если больше никаких проверок делать не нужно, то примерно так наверно :)
  4. Gfdtk
    Offline

    Gfdtk Опытный в 1С

    Регистрация:
    28 апр 2008
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    вместо НайтиПоКоду можно использовать Выбрать()
    Но он ищет точные совпадения.
    Код:
    Номенклатура = Справочники.Номенклатура;
    Отбор = Новый Структура("ТипНоменклатуры");
    Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка();
    Отбор.ТипНоменклатуры = Пусто;
    Выборка = Номенклатура.Выбрать(,,Отбор, "Наименование Убыв");
    Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    Объект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
    Попытка
    Объект.Записать();
    Исключение
    Предупреждение("Не удалось записать объект """ + Объект + """
    |" + ОписаниеОшибки(),60);
    КонецПопытки;
    КонецЦикла;
    
    
    Это из справки 1С
  5. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    НайтиПоКоду вам не поможет, т.к. находит лишь один элемент. Используйте или выборку или запрос.

Поделиться этой страницей