7.7 Работа с DBF

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем PosService, 17 июл 2007.

  1. TopicStarter Overlay
    PosService
    Offline

    PosService

    Регистрация:
    17 июл 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Всем приветы. Столкнулся с такой, возможно простой, задачей. Требуется для некоторых товаров делать "выгрузку" в ДБФ файлы. Тоесть на форме номенклатуры мы делаем "Флажек" с идентификатором "выгрузить". Далее есть отдельная обработка для выгрузки с кнопкой выгрузки и там при нажатии идет формирование файла и запись в него данных. Тоесть идет проверка на наличие флага "выгрузить" и если он есть то код товара записывается. И вот совсем не понимаю как сделать проверку? "Флажок" на форму номенклатуры установил без проблем, но как присваивать ему отмечен он или нет, и при этом еще в обработке делать проверку отмечен он или нет и если отмечен то писать только текущий товар из номенклатуре, а если нет то переходить к следующему. Хелллп :unsure:
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    У "флажка" должен быть идентификатор, а собственно через него и можно проверить вкл\выкл флажок. Т.е. флаг=1 - значит включен и соответственно наоборот.
  3. TopicStarter Overlay
    PosService
    Offline

    PosService

    Регистрация:
    17 июл 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Так хорошо присвоили идентификатор "Добавлять", а как сделать проверку? Писать
    Если Форма.Номенклатура.Добавлять = 1 Тогда
    << производить выгрузку >>
    Иначе
    << Перейти к следующему товару >>
    Конец Если;

    Так чтоль? или как это оформить?
  4. Hamster
    Offline

    Hamster Опытный в 1С

    Регистрация:
    26 янв 2007
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    А флаг, как обозначен через реквизит формы или справочника?
  5. TopicStarter Overlay
    PosService
    Offline

    PosService

    Регистрация:
    17 июл 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Так если я все правильно понял то как реквизит формы

    А может и нет :) в общем Справочники - Номенклатура и по двойному клику открываем и там реквизит наш с идентификатором Добавлять
  6. landay
    Offline

    landay Опытный в 1С

    Регистрация:
    23 янв 2007
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    Если ты кинул на форму флажек, то обращаться к нему надо так
    Если Добавлять = 1 Тогда// галочка стоит
    КонецЕсли

    Если Добавлять = 0 Тогда// галочка не стоит
    КонецЕсли
  7. TopicStarter Overlay
    PosService
    Offline

    PosService

    Регистрация:
    17 июл 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    да но как 1С определяет с какой позицией в номенклатуре идет работа и как осуществить переход к следующей в случаи если флаг 0 (тоесть галочка не стоит)


    PS и вообще есть какая нибудь литература для полных и не очень чайников? что то поискал ничего толком не нашел.
  8. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Да никак не определяет если явно не указать :)

    Код:
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Элем=Спр.ТекущийЭлемент();
    Если Спр.Добавлять=1 Тогда
    //делаем выгрузку
    Иначе
    //не делаем
    КонецЕсли;
    КонецЦикла;
    
    
    Ну соответственно Добавлять должен быть реквизит справочника и принимать значение 0\1 в зависимости от того стоит галка или нет.

Поделиться этой страницей