8.х Работа с com-портом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем kogor, 23 апр 2010.

  1. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте.

    Конфигурация не типовая. Хочу научиться работать с сom-портом.

    Осуществить возможность автоматически считывать показания электронных весов, подключенных к ПК через com-порт по интерфейсу RS-232, и заносить показания в 1С.

    В общих чертах я так понял необходимо подключить внешнюю компоненту (dll) через com-соединение. Что за компонента такая? Что в ней за функции? Можно ли считать данные с com-порта с помощью функций встроенного языка 1С? Или необходимо писать внешнюю компоненту на delphi или другом языке?

    Подскажите, пожалуйста, как это делается? Где можно почитать?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Посмотрите, как сделано в типовых.
    Там все построено на обработке внешнего события.
    Разницы между сканером и весами для работы нету - одно и тоже.
  3. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    А может почитать где то про это можно? Что посоветуете?
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Что именно вы хотите прочитать?
  5. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    Про обработку внешних событий в 8.1. Желательно с синтаксисом, примерами. Как работать с com-портом?????
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Описание принципов есть на диске ИТС в виде статьи.
    Вроде в нете еще народ расписывал на примерах, но навскидку ссылок не приведу...
  7. Gfdtk
    Offline

    Gfdtk Опытный в 1С

    Регистрация:
    28 апр 2008
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    к компюьтеру через сом-порт подключены автомобильные весы Тензо
    Для работы с ними используется внешний драйвер.

    Функция активации драйвера из 1с.
    Запускается при начале работы системы.
    Код:
    Функция АктивироватьВесы() ЭКСПОРТ
    МенеджерВесов = NULL;
    Весы = NULL;
    Если (РольДоступна(Метаданные.Роли.СлужбаОхраны)) Тогда//ИЛИ
    //(ИмяПользователя() = "Ефимов Павел") Тогда
    Попытка
    // менеджер
    МенеджерВесов = ПолучитьCOMОбъект("", "TSHWMain.TSHWM");
    // весы
    Если МенеджерВесов.Scales.Count > 0 Тогда
    Весы = МенеджерВесов.Scales.Items(0);
    ЕстьСоединение = Истина;
    Иначе
    Весы = NULL;
    ЕстьСоединение = Ложь;
    КонецЕсли;
    Исключение
    Сообщить("Ошибка подключения к COM-объекту");
    ЕстьСоединение = Ложь;
    КонецПопытки;
    Иначе
    ЕстьСоединение = Ложь;
    КонецЕсли;
    
    стРезультат = Новый Структура("ЕстьСоединение, МенеджерВесов, Весы");
    стРезультат.ЕстьСоединение = ЕстьСоединение;
    стРезультат.МенеджерВесов = МенеджерВесов;
    стРезультат.Весы = Весы;
    Возврат стРезультат;
    КонецФункции
    
    
    По нажатию кнопки изнужного свойства считывается вес.
    Код:
    Процедура Взвесить(Направление)
    Если ЕстьСоединение Тогда
    Если Направление = "Въезд" Тогда
    ВесНаВъезде = Весы.Weight;
    ИначеЕсли Направление = "Выезд" Тогда
    ВесНаВыезде = Весы.Weight;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
    но для этого нужен драйвер весов под 1С.
  8. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    А что это такое? Код, написанный внутри конфигурации 1С или отдельная программа на каком то другом языке (Delphi, C) ? Или же драйвер поставляется производителем весов?
  9. Gfdtk
    Offline

    Gfdtk Опытный в 1С

    Регистрация:
    28 апр 2008
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    у нас - это отдельная dll.
    Наш драйвер мы брали у производителя.
    Можно поискать в интернете - есть несколько сайтов, где можно купить подобные драйверы.
  10. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    разницы через какой порт подключено оборудование нет. ставим драйвер, в 1с цепляемся к dll'ке, ищем документацию по свойствам и методом dll'ки и юзаем их в 1с. проблем нет :)

Поделиться этой страницей